diff mbox series

[bug#39356] gnu: zrythm: Update to 0.7.474.

Message ID 62a0bdb00943535d29aeb32ef52d7f4234c2696b.camel@zrythm.org
State Accepted
Headers show
Series [bug#39356] gnu: zrythm: Update to 0.7.474. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Jan. 30, 2020, 1:37 p.m. UTC
Hi,

This patch also patches xdg-open so the package properly references it.

Thanks,
Alex

Comments

Marius Bakke Feb. 5, 2020, 8:44 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> This patch also patches xdg-open so the package properly references it.

Applied, thanks!
diff mbox series

Patch

From cba226b892467e6d2d464b2c2082d61914db4ddd Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 30 Jan 2020 13:33:18 +0000
Subject: [PATCH] gnu: zrythm: Update to 0.7.474.

* gnu/packages/music.scm (zrythm): Update to 0.7.474.
[arguments](phases): Patch xdg-open.
---
 gnu/packages/music.scm | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e378e9880b..a8331adc1a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5142,7 +5142,7 @@  and as an LV2 plugin.")
 (define-public zrythm
   (package
     (name "zrythm")
-    (version "0.7.345")
+    (version "0.7.474")
     (source
       (origin
         (method url-fetch)
@@ -5150,13 +5150,21 @@  and as an LV2 plugin.")
                             version ".tar.xz"))
         (sha256
           (base32
-            "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+            "0qq9v8y27zhamcb7nq7pl76874ws8x8cxhp5r685b8binvl9p0az"))))
    (build-system meson-build-system)
    (arguments
     `(#:glib-or-gtk? #t
       #:configure-flags
       `("-Denable_tests=true" "-Dmanpage=true"
-        "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+        "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'patch-xdg-open
+          (lambda _
+            (substitute* "src/utils/io.c"
+                         (("OPEN_DIR_CMD")
+                          (string-append "\"" (which "xdg-open") "\"")))
+            #t)))))
    (inputs
     `(("alsa-lib" ,alsa-lib)
       ("jack" ,jack-1)
-- 
2.25.0