[bug#75990] gnu: hyprlang: Update to 0.6.0.
Commit Message
* gnu/packages/cpp.scm (hyprlang): Update to 0.6.0.
[native-ihputs]: Replace gcc-13 with gcc-14.
Change-Id: I0d0275969570033b225726d53e5df1af87c038d9
---
This is required to make the latest version of hyprpaper work. 'add hyprpaper' patch is sent in bug#75435, and an update has been made to the downstream channel which requires a newer hyprlang, but I don't want to be the one to upstream it as I don't want to steal the channel maintainer's thunder.
gnu/packages/cpp.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
base-commit: f2b3c36bee8c232b026a66de93db38e13fbd7076
Comments
On Sat, Feb 01, 2025 at 05:12 AM, Andrew Wong wrote:
> * gnu/packages/cpp.scm (hyprlang): Update to 0.6.0.
> [native-ihputs]: Replace gcc-13 with gcc-14.
>
Thanks! I already had #75923 in my inbox so I applied that series now
which included these same changes. Sorry for any duplicated work!
John
> Change-Id: I0d0275969570033b225726d53e5df1af87c038d9
> ---
> This is required to make the latest version of hyprpaper work. 'add
> hyprpaper' patch is sent in bug#75435, and an update has been made to
> the downstream channel which requires a newer hyprlang, but I don't
> want to be the one to upstream it as I don't want to steal the channel
> maintainer's thunder.
> gnu/packages/cpp.scm | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index c8199af9ce..add12ef1cc 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -704,7 +704,7 @@ (define-public hyprgraphics
> (define-public hyprlang
> (package
> (name "hyprlang")
> - (version "0.5.3")
> + (version "0.6.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -713,7 +713,7 @@ (define-public hyprlang
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
> + "18f8vlg5ypw35gyi8gy0wqh5jvg1q67qywrb750bx8pk9gi1agx2"))))
> (build-system cmake-build-system)
> (arguments
> (list
> @@ -726,7 +726,8 @@ (define-public hyprlang
> (string-append
> "set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
> all))))))))
> - (native-inputs (list gcc-13 pkg-config))
> + (native-inputs (list gcc-14 ;for c++23 <print> header
> + pkg-config))
> (inputs (list hyprutils))
> (home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")
> (synopsis "Official implementation library for hypr config language")
>
> base-commit: f2b3c36bee8c232b026a66de93db38e13fbd7076
@@ -704,7 +704,7 @@ (define-public hyprgraphics
(define-public hyprlang
(package
(name "hyprlang")
- (version "0.5.3")
+ (version "0.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -713,7 +713,7 @@ (define-public hyprlang
(file-name (git-file-name name version))
(sha256
(base32
- "0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
+ "18f8vlg5ypw35gyi8gy0wqh5jvg1q67qywrb750bx8pk9gi1agx2"))))
(build-system cmake-build-system)
(arguments
(list
@@ -726,7 +726,8 @@ (define-public hyprlang
(string-append
"set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
all))))))))
- (native-inputs (list gcc-13 pkg-config))
+ (native-inputs (list gcc-14 ;for c++23 <print> header
+ pkg-config))
(inputs (list hyprutils))
(home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")
(synopsis "Official implementation library for hypr config language")