diff mbox series

[bug#70924,10/10] gnu: Add python-pplpy.

Message ID 6264215cfd17efe1a12b728b0cecc915963cfab5.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/sagemath.scm (python-pplpy): New variable.

Change-Id: I24d436a03462fd7eb176d34a15683a88814238ea
---
 gnu/packages/sagemath.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 9ccb7eb055..3373885614 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -35,6 +35,7 @@  (define-module (gnu packages sagemath)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages lisp)
@@ -258,6 +259,26 @@  (define-public zn-poly
     (license (list license:gpl2 license:gpl3)) ; dual licensed
     (home-page "https://gitlab.com/sagemath/zn_poly")))
 
+(define-public python-pplpy
+  (package
+    (name "python-pplpy")
+    (version "0.8.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pplpy" version))
+       (sha256
+        (base32 "1zggfj09zkfcabcsasq27vwbhdmkig4yn380gi6wykcih9n22anl"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-cython-3 python-pytest))
+    (inputs (list gmp mpc mpfr pari-gp ppl))
+    (propagated-inputs (list python-cysignals python-gmpy2))
+    (home-page "https://github.com/sagemath/pplpy")
+    (synopsis "Python PPL wrapper")
+    (description "This Python package provides a wrapper to the C++ Parma
+Polyhedra Library (PPL).")
+    (license license:gpl3+)))
+
 (define-public brial
   (package
     (name "brial")