diff mbox series

[bug#48627] Qt6 Base and Module Updates

Message ID 6257645f-aa25-45df-98bb-74f852370cac@www.fastmail.com
State Accepted
Headers show
Series [bug#48627] Qt6 Base and Module Updates | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Eric Brown May 24, 2021, 3:48 p.m. UTC
Patch set attached.

Comments

Eric Brown May 24, 2021, 4:29 p.m. UTC | #1
For convenience, I have made a repo here:

https://gitlab.com/ecbrown/guix.git

On a branch:
   qt6-updates

I would love to hear if someone can build on other architectures, too.

guix build qtbase
guix build qt5compat
etc.

Thanks,
Eric
diff mbox series

Patch

From 41849c504dcde7cfedaa1a629e3c4d8768b83027 Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Mon, 24 May 2021 10:01:29 -0500
Subject: [PATCH 37/37] gnu: qt5compat: New variable.

    * gnu/packages/qt.scm (qt5compat): New variable.
---
 gnu/packages/qt.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0a978f8467..bd136a1028 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -799,6 +799,35 @@  HostData=lib/qt5
     (description "The QtSvg module provides classes for displaying the
  contents of SVG files.")))
 
+(define-public qt5compat
+  (package (inherit qtsvg)
+    (name "qt5compat")
+    (version "6.1.0")
+    (source (origin
+             (method url-fetch)
+             (uri (qt5-urls name version))
+             (sha256
+              (base32
+               "0g6jiw620k02p96mzdkv21frwcgcf4bjggainawbif024z5fdmy7"))
+             (modules '((guix build utils)))
+;;             (snippet
+;;              '(begin
+;;                 (delete-file-recursively "tests/3rdparty")
+;;                 ;; the scion test refers to the bundled 3rd party test code.
+;;                 (substitute* "tests/auto/auto.pro"
+;;                   (("scion") "#"))
+;;                 #t))
+             ))
+    (native-inputs `(("perl" ,perl)))
+    (inputs
+     `(("icu4c" ,icu4c)
+       ("libxkbcommon" ,libxkbcommon)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (synopsis "Qt 5 Compatibility module")
+    (description "The Qt Compatibility module provides contains 
+unsupported Qt 5 APIs.")))
+
 (define-public qtimageformats
   (package (inherit qtsvg)
     (name "qtimageformats")
-- 
2.31.1