diff mbox series

[bug#71278,05/44] gnu: Add rust-lasso-0.7.

Message ID 622462b072e76ff8f8d13359d9bb240e76e4e23d.1717072140.git.murilo@disroot.org
State New
Headers show
Series Add eww. | expand

Commit Message

Murilo May 30, 2024, 3:17 p.m. UTC
* gnu/packages/crates-io.scm (rust-lasso-0.7): New variable.

Change-Id: I49db6ed928dab6d2b8582814d4cda0117005f35f
---
 gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b5691a0d90..0827d1772b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36935,6 +36935,38 @@  (define-public rust-lapack-0.19
     (description "The package provides wrappers for LAPACK (Fortran).")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-lasso-0.7
+  (package
+    (name "rust-lasso")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "lasso" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wkdqn81rm2jf5wklpd0l5477h47yl9jv11xw47mcyix3hg84i26"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-abomonation" ,rust-abomonation-0.7)
+                       ("rust-ahash" ,rust-ahash-0.8)
+                       ("rust-dashmap" ,rust-dashmap-5)
+                       ("rust-deepsize" ,rust-deepsize-0.2)
+                       ("rust-hashbrown" ,rust-hashbrown-0.13)
+                       ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-ahash" ,rust-ahash-0.8)
+                                   ("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-fxhash" ,rust-fxhash-0.2)
+                                   ("rust-lazy-static" ,rust-lazy-static-1)
+                                   ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/Kixiron/lasso")
+    (synopsis "Multithreaded and single threaded string interner")
+    (description
+     "This package provides a multithreaded and single threaded string interner that
+allows strings to be cached with a minimal memory footprint, associating them
+with a unique key that can be used to retrieve them at any time.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-lazy-bytes-cast-5
   (package
     (name "rust-lazy-bytes-cast")