diff mbox series

[bug#64553] gnu: Add emacs-abyss-theme.

Message ID 61bd76ba4342801357108938e1172f9703d2d1d9.1688985066.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64553] gnu: Add emacs-abyss-theme. | expand

Commit Message

Ahmad Draidi July 10, 2023, 10:31 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-abyss-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: e40d6bb7d736bbab7b2b3bec5e5411c5dd91c925
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fb36d7d29d..2cf0c54e23 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2615,6 +2615,30 @@  (define-public emacs-a
 index is considered the key).")
     (license license:gpl3+)))
 
+(define-public emacs-abyss-theme
+  (package
+    (name "emacs-abyss-theme")
+    (version "0.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mgrbyte/emacs-abyss-theme")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07z0djv7h3yrv4iw9n633j6dxzxb4nnzijsqkmz22ik6fbwxg5mh"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/mgrbyte/emacs-abyss-theme")
+    (synopsis "Dark theme with strong colours for Emacs")
+    (description
+     "A dark theme with contrasting colours for Emacs based on the
+@url{https://github.com/andre-richter/emacs-lush-theme, @code{lush}} theme by
+Andre Richter, using the same colours palette as the the built-in
+@code{dichromacy} theme; intended to be suitable
+for red/green colour blind users.")
+    (license license:gpl3+)))
+
 (define-public emacs-ace-jump-mode
   (package
     (name "emacs-ace-jump-mode")