diff mbox series

[bug#54563] gnu: Add wsdd.

Message ID 61b9d1603851cc9d4304d59b8a43899dc804ba67.1648208525.git.simon@netpanic.org
State New
Headers show
Series [bug#54563] gnu: Add wsdd. | expand

Commit Message

Simon Streit March 25, 2022, 11:46 a.m. UTC
* gnu/packages/samba.scm (wsdd): New variable.
---
 gnu/packages/samba.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M March 26, 2022, 10:17 a.m. UTC | #1
Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
> +    (arguments
> +     '(#:install-plan
> +       '(("src/wsdd.py" "bin/wsdd")
> +         ("man/wsdd.1" "share/man/man1/"))))

There are a few tests in 'tests'.  Can they be run?
M March 26, 2022, 10:19 a.m. UTC | #2
Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
> +       (uri (git-reference (url "https://github.com/christgau/wsdd")
> +                           (commit (string-append "v" version))))

This uses NetlinkAddressMonitor, which is Linux-specific.  Could
'supported-systems' be set to only Linux targets (and not, say,
GNU/Hurd)?
Simon Streit April 4, 2022, 6:48 p.m. UTC | #3
Hello Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

> Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
>> +       (uri (git-reference (url "https://github.com/christgau/wsdd")
>> +                           (commit (string-append "v" version))))
>
> This uses NetlinkAddressMonitor, which is Linux-specific.  Could
> 'supported-systems' be set to only Linux targets (and not, say,
> GNU/Hurd)?

I just figured you are meaning that WSDD only supports Linux specific
systems?  It appears so after reading the source code.  I can't tell if
it will work in GNU/Hurd though.  Should the package declaration be
modified to reflect this limitation?
Simon Streit April 4, 2022, 6:52 p.m. UTC | #4
Maxime Devos <maximedevos@telenet.be> writes:

> Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
>> +    (arguments
>> +     '(#:install-plan
>> +       '(("src/wsdd.py" "bin/wsdd")
>> +         ("man/wsdd.1" "share/man/man1/"))))
>
> There are a few tests in 'tests'.  Can they be run?

They don't appear to be proper test files running unit tests or anything
close.  One monitors the address on all network interfaces.  The other
crashes.  The top comment in these files state though that they are “not
really a test case, but a PoC for getting notified about changes in
network addresses.”

I don't think it will be necessary to have then run while packaging.
M April 4, 2022, 9:58 p.m. UTC | #5
Simon Streit schreef op ma 04-04-2022 om 20:48 [+0200]:
> Hello Maxime,
> 
> Maxime Devos <maximedevos@telenet.be> writes:
> 
> > Simon Streit schreef op vr 25-03-2022 om 12:46 [+0100]:
> > > +       (uri (git-reference (url "https://github.com/christgau/wsdd")
> > > +                           (commit (string-append "v" version))))
> > 
> > This uses NetlinkAddressMonitor, which is Linux-specific.  Could
> > 'supported-systems' be set to only Linux targets (and not, say,
> > GNU/Hurd)?
> 
> I just figured you are meaning that WSDD only supports Linux specific
> systems?  It appears so after reading the source code.  I can't tell if
> it will work in GNU/Hurd though.  Should the package declaration be
> modified to reflect this limitation? 

netlink is IIUC (currently) a Linux-specific interface.  Though
<https://github.com/christgau/wsdd/issues/80> mentions FreeBSD so maybe
it's ok after all.  As such, I would optimistically assume it works on
the Hurd as well.

Greetings,
Maxime.
Vagrant Cascadian Sept. 1, 2023, 11:37 p.m. UTC | #6
On 2022-03-25, Simon Streit wrote:
> * gnu/packages/samba.scm (wsdd): New variable.

This was merged as:

14359befa92d2d54af0e584724610d8a31f5ac63 gnu: Add wsdd.

And updated to a newer version in:

79c2af7394a8a541fa2ed0126272025b09aa05cd gnu: wsdd: Update to 0.7.1.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..21a5fe8617 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -500,3 +500,29 @@  (define-public ppp
     ;; chat is public domain.
     (license (list bsd-3 bsd-4 gpl2+ public-domain))))
 
+(define-public wsdd
+  (package
+    (name "wsdd")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference (url "https://github.com/christgau/wsdd")
+                           (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04an2w6hamnai668ag4vq8x0i09fsg2jrayb4a7ar0x6bn837k7m"))))
+    (build-system copy-build-system)
+    (inputs
+     `(("python" ,python)))
+    (arguments
+     '(#:install-plan
+       '(("src/wsdd.py" "bin/wsdd")
+         ("man/wsdd.1" "share/man/man1/"))))
+    (home-page "https://github.com/christgau/wsdd")
+    (synopsis "A Web Service Discovery host daemon")
+    (description "This daemon allows (Samba) hosts to be found by Web
+Service Dicovery Clients.  It also implements the client side of the
+discovery protocol which allows to search for devices implementing
+WSD.")
+    (license expat)))