diff mbox series

[bug#56769] gnu: wrap-python3: Clarify relationship with wrapped package.

Message ID 61a803dbf366b7ab4365b91d23663a8620b64c7f.1658779495.git.philip@philipmcgrath.com
State Accepted
Headers show
Series [bug#56769] gnu: wrap-python3: Clarify relationship with wrapped package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath July 25, 2022, 8:05 p.m. UTC
The previous description could give the impression that the user faced a
choice between `python` and `python3`, but could not have both at once.
In fact, the packages `python-wrapper` and `python-minimal-wrapper`
already provide both sets of names.

* gnu/packages/python.scm (wrap-python3)[description]: Tweak.
---
 gnu/packages/python.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: 212ca81895b2baa819ea11a308ad21880b84a546

Comments

Ludovic Courtès Aug. 9, 2022, 2:58 p.m. UTC | #1
Hi,

Philip McGrath <philip@philipmcgrath.com> skribis:

> The previous description could give the impression that the user faced a
> choice between `python` and `python3`, but could not have both at once.
> In fact, the packages `python-wrapper` and `python-minimal-wrapper`
> already provide both sets of names.
>
> * gnu/packages/python.scm (wrap-python3)[description]: Tweak.

Applied!

> +@command{python} package: this package uses the @command{python} package as a
> +propagated input, so installing this package already makes both the versioned
> +and the unversioned commands available.")))

Change @command to @code above.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4fcee28ba3..c815343d5d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -662,10 +663,12 @@  (define* (wrap-python3 python
     (synopsis "Wrapper for the Python 3 commands")
     (description
      "This package provides wrappers for the commands of Python@tie{}3.x such
-that they can be invoked under their usual name---e.g., @command{python}
+that they can also be invoked under their usual names---e.g., @command{python}
 instead of @command{python3} or @command{pip} instead of @command{pip3}.
 To function properly, this package should not be installed together with the
-@command{python} package.")))
+@command{python} package: this package uses the @command{python} package as a
+propagated input, so installing this package already makes both the versioned
+and the unversioned commands available.")))
 
 (define-public python-wrapper (wrap-python3 python))
 (define-public python-minimal-wrapper (wrap-python3 python-minimal))