[bug#78533] gnu: Add featherpad.
Commit Message
* gnu/packages/text-editors.scm (featherpad): New variable.
Change-Id: I329b6ba354caa8f1646735c2646b05dd00d2aa2f
---
gnu/packages/text-editors.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
base-commit: 11bc17c409d77cd1af91e30b5b9f6a73f873a152
@@ -38,6 +38,7 @@
;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -102,6 +103,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages hunspell)
#:use-module (gnu packages image)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
@@ -1983,3 +1985,27 @@ (define-public dte
syntax highlighting, customizable color scheme (including support for 24-bit true
colours), kitty keyboard protocol, editorconfig support, amongst other features.")
(license license:gpl2)))
+
+(define-public featherpad
+ (package
+ (name "featherpad")
+ (version "1.6.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tsujan/FeatherPad")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dg99d17hlffmpcm9l1dbwkw5ympbxxa2mmi6qzljd5jx2sfb3hv"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;no tests
+ (inputs (list qtbase
+ qtsvg
+ hunspell))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/tsujan/FeatherPad")
+ (synopsis "Lightweight Qt5 plain-text editor")
+ (description "FeatherPad is a lightweight text editor based on Qt5.")
+ (license license:expat)))