diff mbox series

[bug#65556,v2] gnu: Add Sirikali.

Message ID 6184a928bbd61c376a19af6821e13567f95d0e82.1700538349.git.aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#65556,v2] gnu: Add Sirikali. | expand

Commit Message

Aaron Covrig Nov. 21, 2023, 3:45 a.m. UTC
* gnu/packages/file-systems.scm (sirikali): New variable

Change-Id: Ie46cf269dac1ba842d935221b2372fb3d8a6ea2d
---
Quick update to also remove the '-DCMAKE_BUILD_TYPE=RELEASE' that was   
mentioned as being unnecessary.

V/r,

Aaron Covrig

 gnu/packages/file-systems.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: d987b75618a62c95c030e7ca53e0972e700c4f06

Comments

Leo Famulari Dec. 29, 2023, 10:15 p.m. UTC | #1
On Mon, Nov 20, 2023 at 10:45:49PM -0500, Aaron Covrig via Guix-patches via wrote:
> * gnu/packages/file-systems.scm (sirikali): New variable

Thanks for this!

I tweaked the synopsis and description, and I also changed the license
to 'gpl2+', because all of the .cpp files I looked at describe the
license as, to paraphrase, "GPL 2 or any later version".

Pushed as f76ca2b0e894c244d5011a32b30dee8fd874e322
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc061a5958..a69e4c0eb6 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;; Copyright © 2021, 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;; Copyright © 2022 Brian Cully <bjc@spork.org>
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,8 +65,10 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-check)
@@ -81,6 +84,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages nfs)
   #:use-module (gnu packages onc-rpc)
   #:use-module (gnu packages openldap)
+  #:use-module (gnu packages password-utils)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages photo)
@@ -91,6 +95,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rsync)
   #:use-module (gnu packages sssd)
@@ -2112,3 +2117,30 @@  (define-public dwarfs
 
 @end itemize\n")
     (license license:gpl3)))
+
+(define-public sirikali
+  (package
+    (name "sirikali")
+    (version "1.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mhogomchungu/sirikali")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ;No tests
+       #:configure-flags '("-DQT5=true")))
+    (inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
+    (native-inputs (list pkg-config))
+    (home-page "https://mhogomchungu.github.io/sirikali/")
+    (synopsis
+     "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+    (description "@dfn{SiriKali} is a Qt/C++ GUI application that manages
+ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs
+based encrypted folders")
+    (license (list license:gpl3 license:gpl2))))