diff mbox series

[bug#64708,8/8] gnu: mig: Update to 1.8+git20230520.

Message ID 61835f33c6fee35457c7277e3216c10c15d0a391.1689685375.git.janneke@gnu.org
State New
Headers show
Series Fix cross build and native build for the Hurd. | expand

Commit Message

Janneke Nieuwenhuizen July 18, 2023, 1:15 p.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

Now that mig-boot0 has been updated not to use mig's source, we can
safely update mig.

* gnu/packages/hurd.scm (mig)[source]: Update to 1.8+git20230520.
---
 gnu/packages/hurd.scm | 20 ++++++++------------
 1 file changed, 8 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès July 18, 2023, 9:20 p.m. UTC | #1
Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> From: Josselin Poiret <dev@jpoiret.xyz>
>
> Now that mig-boot0 has been updated not to use mig's source, we can
> safely update mig.
>
> * gnu/packages/hurd.scm (mig)[source]: Update to 1.8+git20230520.

This one could be avoided, at least for now, due to
4e11cac6be68a674c16965dc74e7da54cd3168df and the tarball we’re hosting
on ftp.gnu.org.  (We could also avoid the corresponding change in
‘mig-boot0’.)

But really, either way is fine, as long as both cross-compilation and
native compilation work after that.  :-)

Ludo’.
Janneke Nieuwenhuizen July 18, 2023, 9:38 p.m. UTC | #2
Ludovic Courtès writes:

Hi!

> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> From: Josselin Poiret <dev@jpoiret.xyz>
>>
>> Now that mig-boot0 has been updated not to use mig's source, we can
>> safely update mig.
>>
>> * gnu/packages/hurd.scm (mig)[source]: Update to 1.8+git20230520.
>
> This one could be avoided, at least for now, due to
> 4e11cac6be68a674c16965dc74e7da54cd3168df and the tarball we’re hosting
> on ftp.gnu.org.  (We could also avoid the corresponding change in
> ‘mig-boot0’.)

I believe we'd rather re-instate this change to build mig fram git
so that we can do --with-commit to track all the neat things that
upstream is doing, right Josselin?

> But really, either way is fine, as long as both cross-compilation and
> native compilation work after that.  :-)

Sure!
Josselin Poiret July 19, 2023, 9:08 a.m. UTC | #3
Hi Janneke and Ludo,

Janneke Nieuwenhuizen <janneke@gnu.org> writes:

> Ludovic Courtès writes:
>> This one could be avoided, at least for now, due to
>> 4e11cac6be68a674c16965dc74e7da54cd3168df and the tarball we’re hosting
>> on ftp.gnu.org.  (We could also avoid the corresponding change in
>> ‘mig-boot0’.)
>
> I believe we'd rather re-instate this change to build mig fram git
> so that we can do --with-commit to track all the neat things that
> upstream is doing, right Josselin?

Yes, that was the point, we don't want to upload a new tarball to the
ftp all the time (esp. because I can't do it myself :) ).

Best,
Janneke Nieuwenhuizen July 19, 2023, 9:32 a.m. UTC | #4
Josselin Poiret writes:

Hi Josselin and Ludo,

> Janneke Nieuwenhuizen <janneke@gnu.org> writes:
>
>> Ludovic Courtès writes:
>>> This one could be avoided, at least for now, due to
>>> 4e11cac6be68a674c16965dc74e7da54cd3168df and the tarball we’re hosting
>>> on ftp.gnu.org.  (We could also avoid the corresponding change in
>>> ‘mig-boot0’.)
>>
>> I believe we'd rather re-instate this change to build mig fram git
>> so that we can do --with-commit to track all the neat things that
>> upstream is doing, right Josselin?
>
> Yes, that was the point, we don't want to upload a new tarball to the
> ftp all the time (esp. because I can't do it myself :) ).

So, that's what I've done, I think we're OK!

Thanks for the confirmation,
Janneke
diff mbox series

Patch

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3785c47750..4064a9e2e8 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -91,24 +91,20 @@  (define-public gnumach-headers
 (define-public mig
   (package
     (name "mig")
-    (version "1.8+git20220827")
+    (version "1.8+git20230520")
     (source (origin
-              (method url-fetch)
-              ;; XXX: Version 2.35 of glibc can only be built with an
-              ;; unreleased version of MiG:
-              ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
-              ;; It cannot be fetched from Git though, as the extra dependency
-              ;; on Autoconf/Automake would complicate bootstrapping.
-              (uri (string-append "mirror://gnu/guix/mirror/mig-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.savannah.gnu.org/git/hurd/mig.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
-              (patches (search-patches "mig-cpu.h-generation.patch"))))
+                "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
     (build-system gnu-build-system)
     ;; Flex is needed both at build and run time.
     (inputs (list gnumach-headers flex))
-    (native-inputs (list flex bison))
+    (native-inputs (list autoconf automake flex bison))
     (arguments
      (list #:tests? #f
            #:phases