diff mbox series

[bug#56729,RFC,v2,12/29] gnu: Add python-memory-allocator.

Message ID 612568de06686815affc8ea7eaa12523e53e9ca1.1659973115.git.guix@ikherbers.com
State New
Headers show
Series Add sagemath. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

vicvbcun Aug. 8, 2022, 3:45 p.m. UTC
* gnu/packages/sagemath.scm (python-memory-allocator): New variable.
---
 gnu/packages/sagemath.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 1237ff8e04..2e9de70e4a 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -356,3 +356,20 @@  (define-public ratpoints
 a given height bound on a hyperelliptic curve in a very efficient way,
 by using an optimized quadratic sieve algorithm.")
     (license license:gpl2+)))
+
+(define-public python-memory-allocator
+  (package
+    (name "python-memory-allocator")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "memory_allocator" version))
+              (sha256
+               (base32
+                "0qiijpv8zr7c5rjy64i4q3rb8qhn6v4yms5mza4p86y0w4m5r00k"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-cython))
+    (home-page "https://github.com/sagemath/memory_allocator")
+    (synopsis "An extension class to allocate memory easily with cython")
+    (description "An extension class to allocate memory easily with cython")
+    (license license:gpl3)))