diff mbox series

[bug#72594,3/7] gnu: Add go-github-com-mattbaird-jsonpatch.

Message ID 610f6bc2f624a997e49b77338970440b39e8b426.1723483365.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some of the Google gvisor dependencies. | expand

Commit Message

Artyom V. Poptsov Aug. 12, 2024, 5:26 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mattbaird-jsonpatch): New variable.

Change-Id: I571c51f2141dbba53067f4279003a4604f21b1a4
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2d5844669e..82d9616b71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3636,6 +3636,35 @@  (define-public go-github-com-magiconair-properties
     (description "Java properties scanner for Go")
     (license license:bsd-2)))
 
+(define-public go-github-com-mattbaird-jsonpatch
+  (package
+    (name "go-github-com-mattbaird-jsonpatch")
+    (version "0.0.0-20171005235357-81af80346b1a")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mattbaird/jsonpatch")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ll22kpf75m72r7i5ddg3r87gdlagbj2x24bppgbi8jp018pdq95"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/mattbaird/jsonpatch"))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/mattbaird/jsonpatch")
+    (synopsis "JSON Patch library for Go")
+    (description
+     "@url{http://jsonpatch.com/, JSON Patch} implementation for Go as
+specified in @url{https://datatracker.ietf.org/doc/html/rfc6902/, RFC 6902} from the
+IETF.
+
+JSON Patch allows you to generate JSON that describes changes you want to make to a
+document, so you don't have to send the whole doc.  JSON Patch format is supported by
+HTTP PATCH method, allowing for standards based partial updates via REST APIs.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-pelletier-go-toml
   (package
     (name "go-github-com-pelletier-go-toml")