diff mbox series

[bug#57540,1/6] gnu: Add ocaml-atd.

Message ID 608b4f6bdcbd56e28ba9ab0c34401790@disroot.org
State Accepted
Headers show
Series [bug#57540,1/6] gnu: Add ocaml-atd. | expand

Commit Message

Garek Dyszel Sept. 2, 2022, 3:20 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-atd)
---
  gnu/packages/ocaml.scm | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)

+good fit with a variety of data formats.")
+    ;; Modified BSD license
+    (license (license:non-copyleft "LICENSE.md"))))
--
2.37.2
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 59f324e..c8ffef5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8843,3 +8843,38 @@  (define-public ocaml-elpi
  ELPI is free software released under the terms of LGPL 2.1 or above.")
      (license license:lgpl2.1)))

+(define-public ocaml-atd
+  (package
+    (name "ocaml-atd")
+    (version "2.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/ahrefs/atd/releases/download/" 
version
+                    "/atdts-" version ".tbz"))
+              (sha256
+               (base32
+                
"1609hlj2snpvxnmmg892ic01hv3chdhfmsd2khdw9np9lh4p9lkp"))))
+    (build-system dune-build-system)
+    (arguments
+     `(;; Error: Don't know about directory test specified on the 
command line!
+       #:tests? #f))
+    (propagated-inputs (list ocaml-menhir
+                             ocaml-easy-format
+                             ocaml-odoc
+                             ocaml-re
+                             ocaml-camlp-streams
+                             ocaml-biniou
+                             ocaml-yojson
+                             ocaml-cmdliner
+                             ocaml-menhir))
+    (native-inputs (list ocaml-alcotest python))
+    (home-page "https://github.com/ahrefs/atd")
+    (synopsis "Parser for the ATD data format description language")
+    (description
+     "ATD is the OCaml library providing a parser for the ATD language
+and various utilities.  ATD stands for Adjustable Type Definitions in
+reference to its main property of supporting annotations that allow a