From e1b2a243c1d96f1759cb4895448a78d9701ac4ff Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 24 Dec 2019 08:04:16 -0500
Subject: [PATCH] gnu: Add gnome-font-viewer.
* gnu/packages/gnome.scm (gnome-font-viewer). New Variable.
---
gnu/packages/gnome.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -711,6 +711,32 @@ and keep up to date translations of documentation.")
(description "Disk management utility for GNOME.")
(license license:gpl2+)))
+(define-public gnome-font-viewer
+ (package
+ (name "gnome-font-viewer")
+ (version "3.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-font-viewer/"
+ (version-major+minor version) "/gnome-font-viewer-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wwnx2zrlbd2d6np7m9s78alx6j6ranrnh1g2z6zrv9qcj8rpzz5"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib" ,glib)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gtk+" ,gtk+)))
+ (synopsis "GNOME Fonts")
+ (description "Application to show you the fonts installed on your computer for your use as thumbnails. Selecting any thumbnails shows the full view of how the font would look under various sizes.")
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-font-viewer")
+ (license license:gpl2+)))
+
(define-public gcr
(package
(name "gcr")
--
2.24.1