[bug#75575] gnu: kakoune: Add search path
Commit Message
* gnu/packages/text-editors.scm (kakoune): Add KAKOUNE_RUNTIME to search
paths. This is needed to eg. package plugins, or to have a stable target
for the symlink inside `${userconf}/autoload` to `@{runtime}/autoload`
(see Kakoune manual).
Change-Id: I55a48696f20e13499206b573a9b07895250d791c
---
This is my first contribution... If I forgot any guidelines, let me know!
This patch would prepare the way for some kakoune plugin packages, but I'll
first consult the guix-devel mailing list to see if & how that is alright.
This patch should be nonetheless useful on its own.
gnu/packages/text-editors.scm | 5 +++++
1 file changed, 5 insertions(+)
base-commit: 21574796e98f897d86a0909e31fbb321ebb6e399
@@ -366,6 +366,11 @@ (define-public kakoune
"\";\n " line)))))
(delete 'configure)))) ; no configure script
(native-inputs (list pkg-config))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "KAKOUNE_RUNTIME")
+ (separator #f) ;pretty sure kakoune can handle only 1 runtime dir
+ (files (list "share/kak")))))
(synopsis "Vim-inspired code editor")
(description
"Kakoune is a code editor heavily inspired by Vim, as such most of its