[bug#77159,5/7] gnu: zathura-djvu: Update to 0.2.10.
Commit Message
* gnu/packages/pdf.scm (zathura-djvu): Update to 0.2.10.
[arguments] <#:phases>: Remove unneeded 'patch-plugin-directory phase
Change-Id: I4be25dcafe02cbd94bae764054d1241d07a5a203
---
gnu/packages/pdf.scm | 34 +++++++++++-----------------------
1 file changed, 11 insertions(+), 23 deletions(-)
@@ -582,32 +582,20 @@ (define-public zathura-ps
(define-public zathura-djvu
(package
(name "zathura-djvu")
- (version "0.2.9")
- (source (origin
- (method url-fetch)
- (uri
- (string-append "https://pwmt.org/projects/zathura-djvu/download/zathura-djvu-"
- version ".tar.xz"))
- (sha256
- (base32
- "0062n236414db7q7pnn3ccg5111ghxj3407pn9ri08skxskgirln"))))
+ (version "0.2.10")
+ (source
+ (origin (method url-fetch)
+ (uri (string-append "https://pwmt.org/projects/zathura-djvu"
+ "/download/zathura-djvu-" version ".tar.xz"))
+ (sha256
+ (base32 "15cd6ccizaizhk8x25vky7nspgb83129zxxszk9xfv5756cxis9j"))))
(native-inputs (list pkg-config))
- (inputs
- (list djvulibre zathura))
+ (inputs (list djvulibre zathura))
(build-system meson-build-system)
(arguments
- `(#:tests? #f ; package does not contain tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-plugin-directory
- ;; Something of a regression in 0.2.8: the new Meson build system
- ;; now hard-codes an incorrect plugin directory. Fix it.
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "meson.build"
- (("(install_dir:).*" _ key)
- (string-append key
- "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
- #t)))))
+ (list #:tests? #f ; package does not contain tests
+ #:configure-flags
+ #~(list (string-append "-Dplugindir=" #$output "/lib/zathura"))))
(home-page "https://pwmt.org/projects/zathura-djvu/")
(synopsis "DjVu support for zathura (DjVuLibre backend)")
(description "The zathura-djvu plugin adds DjVu support to zathura