diff mbox series

[bug#70235,1/2] gnu: widelands: Update to 1.2.

Message ID 5f83354f3c946d1f21b3e4b9a48169a450649b88.1712392635.git.timotej.lazar@araneo.si
State New
Headers show
Series Update widelands | expand

Commit Message

Timotej Lazar April 6, 2024, 8:44 a.m. UTC
* gnu/packages/games.scm (widelands): Update to 1.2.
[inputs]: Drop boost, curl.
[native-inputs]: Replace python-wrapper with python.

Change-Id: I1a98739a5da801d3686acf152989c8ce15f16a90
---
 gnu/packages/games.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6e26a15f56..78aedca434 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5786,7 +5786,7 @@  (define-public warzone2100
 (define-public widelands
   (package
     (name "widelands")
-    (version "1.1")
+    (version "1.2")
     (source
      (origin
        (method git-fetch)
@@ -5795,7 +5795,7 @@  (define-public widelands
               (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "07wbalwdmml9vdh9nh50svnsw4sdj9nnp32azbss8vzq5mxmzvbx"))
+        (base32 "1m9hn1sh1siggribzsq79k7p0lggdw41ji7zdl6h648cjak9mdsp"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -5830,11 +5830,9 @@  (define-public widelands
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)))
+       ("python" ,python)))
     (inputs
      `(("asio" ,asio)
-       ("curl" ,curl)
-       ("boost" ,boost)
        ("glew" ,glew)
        ("icu4c" ,icu4c)
        ("libpng" ,libpng)