[bug#75077,v2] gnu: Add swayimg.

Message ID 5f74d533e59b0ac1bd26a5f276f8332e0fe02497.1736072247.git.wongandj@icloud.com
State New
Headers
Series [bug#75077,v2] gnu: Add swayimg. |

Commit Message

Andrew Wong Jan. 5, 2025, 10:17 a.m. UTC
  * gnu/packages/image-viewers.scm (swayimg): New variable.

Change-Id: I5e6d2d01278d34df412a128a67e2ead46ad5afc2
---
 gnu/packages/image-viewers.scm | 51 ++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)


base-commit: e383e8e34097b064d4baa4207673c6ba30617347
  

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index cb4e903f39..c3f4b8d8de 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -111,6 +111,57 @@  (define-module (gnu packages image-viewers)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages))
 
+(define-public swayimg
+  (package
+    (name "swayimg")
+    (version "3.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/artemsen/swayimg")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "15nqb1igikkvrzx3dhyj9msynfpvrnqvql6plqm8fhg10fbimfhd"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags '(,(string-append "-Dversion=" version))))
+    (native-inputs (list pkg-config))
+    (inputs (list fontconfig
+                  freetype
+                  giflib
+                  ijg-libjpeg
+                  imath
+                  json-c
+                  libavif
+                  libexif
+                  libheif
+                  libjxl
+                  libpng
+                  librsvg
+                  libtiff
+                  libwebp
+                  libxkbcommon
+                  openexr
+                  wayland
+                  wayland-protocols
+                  bash-completion))
+    (home-page "https://github.com/artemsen/swayimg")
+    (synopsis "Customizable and lightweight image viewer for Wayland")
+    (description
+     "Fully customizable and lightweight image viewer for Wayland based
+display servers.  Support for the most popular image formats (JPEG,
+JPEG XL, PNG, GIF, SVG, WebP, HEIF/AVIF, AV1F/AVIFS, TIFF, EXR, BMP,
+PNM, TGA, QOI, DICOM, Farbfeld).  Fully customizable keyboard bindings,
+colors, and many other parameters.  Loading images from files and
+pipes.  Gallery and viewer modes with slideshow and animation support.
+Preload images in a separate thread.  Cache in memory, no data is
+written to permanent storage.  Sway integration mode: the application
+creates an \"overlay\" above the currently active window, which gives
+the illusion that you are opening the image directly in a terminal
+window.")
+    (license license:expat)))
+
 (define-public ytfzf
   (package
     (name "ytfzf")