diff mbox series

[bug#42473] gnu: zrythm: Update to 0.8.694.

Message ID 5f6b65912ab95729ddf4bf4b4121dd1ba7e5f247.camel@zrythm.org
State Accepted
Headers show
Series [bug#42473] gnu: zrythm: Update to 0.8.694. | expand

Commit Message

Alexandros Theodotou Sept. 11, 2020, 4:52 p.m. UTC
Hi,

On Fri, 2020-09-11 at 17:36 +0200, Ludovic Courtès wrote:
> This requires Meson 0.55 so it doesn’t work on master.
> 
> Could you add Meson 0.55 and have zrythm use it?

Done. Not sure exactly what you expect but I added an additional
meson55 package and used it like #:meson ,meson55. Feel free to edit it
accordingly.

> > diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> > index b674019b8f..01f8a6bfc2 100644
> > --- a/gnu/packages/web.scm
> > +++ b/gnu/packages/web.scm
> > @@ -5027,6 +5027,7 @@ written in C.  It is developed as part of the
> > NetSurf project.")
> >    (package
> >      (name "libcyaml")
> >      (version "1.0.1")
> > +    (version "1.1.0")
> >      (source
> >       (origin
> >         (method git-fetch)
> > @@ -5036,6 +5037,7 @@ written in C.  It is developed as part of the
> > NetSurf project.")
> >         (file-name (git-file-name name version))
> >         (sha256
> >          (base32
> > "0h5ydyqdl8kzh526np3jsi0pm7ks16nh1hjkdsjcd6pacw7y6i6z"))))
> > +        (base32
> > "1al5cbild3qimm59rmaj3i8m57qhinwshz7r67p7fqsccijrz71b"))))
> 
> This one is obviously broken.  I tried to redo it by hand, but then
> zrythm would fail to build.

Err, gitg miss, I only selected the additions to stage. Fixed.

> Could you resend the other 3 patches, making sure everything works on
> master?

Please find them attached.

Thanks,
Alex

Comments

Ludovic Courtès Sept. 13, 2020, 9:37 p.m. UTC | #1
Hi,

Alexandros Theodotou <alex@zrythm.org> skribis:

> On Fri, 2020-09-11 at 17:36 +0200, Ludovic Courtès wrote:
>> This requires Meson 0.55 so it doesn’t work on master.
>> 
>> Could you add Meson 0.55 and have zrythm use it?
>
> Done. Not sure exactly what you expect but I added an additional
> meson55 package and used it like #:meson ,meson55. Feel free to edit it
> accordingly.
>
>> > diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
>> > index b674019b8f..01f8a6bfc2 100644
>> > --- a/gnu/packages/web.scm
>> > +++ b/gnu/packages/web.scm
>> > @@ -5027,6 +5027,7 @@ written in C.  It is developed as part of the
>> > NetSurf project.")
>> >    (package
>> >      (name "libcyaml")
>> >      (version "1.0.1")
>> > +    (version "1.1.0")
>> >      (source
>> >       (origin
>> >         (method git-fetch)
>> > @@ -5036,6 +5037,7 @@ written in C.  It is developed as part of the
>> > NetSurf project.")
>> >         (file-name (git-file-name name version))
>> >         (sha256
>> >          (base32
>> > "0h5ydyqdl8kzh526np3jsi0pm7ks16nh1hjkdsjcd6pacw7y6i6z"))))
>> > +        (base32
>> > "1al5cbild3qimm59rmaj3i8m57qhinwshz7r67p7fqsccijrz71b"))))
>> 
>> This one is obviously broken.  I tried to redo it by hand, but then
>> zrythm would fail to build.
>
> Err, gitg miss, I only selected the additions to stage. Fixed.
>
>> Could you resend the other 3 patches, making sure everything works on
>> master?
>
> Please find them attached.

Applied with the following tweaks:

  • Renamed Meson variable to ‘meson-0.55’.

  • Replaced libcyaml upgrade with my own version since I got a
    different hash than the one your patch had.  If you still have a
    different version, please check whether there are differences.

Thanks!

Ludo’.
diff mbox series

Patch

From 434b1ee36502451959328b1fc426acdf44b4f980 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 11 Sep 2020 17:27:56 +0100
Subject: [PATCH 1/4] gnu: Add meson55.

* gnu/packages/build-tools.scm (meson55): New variable.
---
 gnu/packages/build-tools.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 7213c1bd0b..45471dc954 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -211,6 +211,22 @@  files}, are written in a custom domain-specific language (@dfn{DSL}) that
 resembles Python.")
     (license license:asl2.0)))
 
+;; Added temporarily for packages that need it.
+;; TODO: Remove when core-updates is merged.
+(define-public meson55
+  (package
+    (inherit meson)
+    (name "meson55")
+    (version "0.55.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/mesonbuild/meson/"
+                                  "releases/download/" version  "/meson-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1070kjiirxxdfppmrhi3wsc6rykay1zlciqrzayjhjg0hkw42mrv"))))))
+
 (define-public meson-for-build
   (package
     (inherit meson)
-- 
2.27.0