diff mbox series

[bug#73466,03/16] gnu: Add ocaml-arg-complete.

Message ID 5f695fcb420d8a2a25535a8cfa705d93955d79f6.1727250772.git.herman@rimm.ee
State New
Headers show
Series [bug#73466,01/16] gnu: Add ocaml-jsonrpc. | expand

Commit Message

Herman Rimm Sept. 25, 2024, 8:02 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-arg-complete): Add variable.

Change-Id: I9f6b5345ccb79f7774451656e8a9a4422a84d2d6
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e21787b5a1..0cb2e61c93 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -656,6 +656,28 @@  (define-public camlidl
 code for interfacing Caml with C from an IDL description of the C functions.")
     (license license:lgpl2.1)))
 
+(define-public ocaml-arg-complete
+  (package
+    (name "ocaml-arg-complete")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/sim642/ocaml-arg-"
+                           "complete/releases/download/" version
+                           "/arg-complete-" version ".tbz"))
+       (sha256
+        (base32
+          "1g12baxcw69gsbmf90c13zkqm21w0kpafiafanmhba9wws2mf3pk"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-cppo ocaml-odoc))
+    (native-inputs (list ocaml-ounit2))
+    (home-page "https://github.com/sim642/ocaml-arg-complete")
+    (synopsis "Bash completion support for Stdlib.Arg")
+    (description
+      "This package provides bash completion support for Stdlib.Arg.")
+    (license license:expat)))
+
 (define-public ocaml-extlib
   (package
     (name "ocaml-extlib")