diff mbox series

[bug#66856,v2,7/7] gnu: Add plasma-shell-wallpaper-active-blur.

Message ID 5f0f624334ad3897401a69673c80531c7f472c7a.1698969760.git.sughosha@disroot.org
State New
Headers show
Series Add some themes and extensions for KDE Plasma. | expand

Commit Message

Sughosha Nov. 3, 2023, 12:14 a.m. UTC
* gnu/packages/kde-xyz.scm (plasma-shell-wallpaper-active-blur): New variable.

Change-Id: I879d939ca58f32514a6ac69477aadcc285a2d750
---
 gnu/packages/kde-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-xyz.scm b/gnu/packages/kde-xyz.scm
index 1fc44bd846..1407720a8a 100644
--- a/gnu/packages/kde-xyz.scm
+++ b/gnu/packages/kde-xyz.scm
@@ -227,3 +227,29 @@  (define-public plasma-shell-applet-window-title
      "This plasmoid shows the current window title and icon in Plasma panels or
 Latte Dock.")
     (license license:gpl2+)))
+
+(define-public plasma-shell-wallpaper-active-blur
+  (package
+    (name "plasma-shell-wallpaper-active-blur")
+    (version "2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+          (url "https://github.com/bouteillerAlan/blurredwallpaper")
+          (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b688d4p8n1wkhw3bp1zhxi5xbx806fy5hcgc8jrjj2kaclk408n"))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       `(("." "/share/plasma/wallpapers/a2n.blur"
+          #:include-regexp ("/assets/" "/contents/" "metadata.json")))))
+    (home-page "https://github.com/bouteillerAlan/blurredwallpaper")
+    (synopsis "Blurred wallpaper plugin for Plasma shell")
+    (description
+     "This Plasma wallpaper plugin blurs the wallpaper when a window is
+active.")
+    (license license:gpl2+)))