diff mbox series

[bug#71084,22/26] gnu: Add python-viresclient.

Message ID 5ee86fb18c6cd89c26764d131e9125bd1ce9009b.1716242564.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/05. | expand

Commit Message

Sharlatan Hellseher May 20, 2024, 10:12 p.m. UTC
* gnu/packages/astronomy.scm (python-viresclient): New variable.

Change-Id: I690a6d8f1fc80dde1605f50d09f540d556fa881b
---
 gnu/packages/astronomy.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 13387c3349..122be3b260 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5214,6 +5214,37 @@  (define-public python-skyfield
 orbit around the Earth.")
     (license license:expat)))
 
+(define-public python-viresclient
+  (package
+    (name "python-viresclient")
+    (version "0.11.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "viresclient" version))
+       (sha256
+        (base32 "1npn5ka0cflvl6ngf5b08z59dh79hnyh5v2z4sf0872q9zkwmjjw"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-flit-core python-pytest))
+    (propagated-inputs
+     (list python-cdflib
+           python-jinja2
+           python-netcdf4
+           python-pandas
+           python-requests
+           python-tables
+           python-tqdm
+           python-xarray))
+    (home-page "https://viresclient.readthedocs.io/en/latest/")
+    (synopsis "Python client for interacting with a VirES server")
+    (description
+     "This package provides a Python client for interacting with a
+@code{VirES} server, of which there are two: VirES for
+@url{https://vires.services, Swarm} and VirES for
+@url{https://aeolus.services, Aeolus}")
+    (license license:expat)))
+
 (define-public python-wiimatch
   (package
     (name "python-wiimatch")