diff mbox series

[bug#38115] gnu: Add dpf-plugins.

Message ID 5ec075a5ad2b9e880909217dc3d7b300bfc3ea94.camel@zrythm.org
State Accepted
Headers show
Series [bug#38115] gnu: Add dpf-plugins. | expand

Commit Message

Alexandros Theodotou Nov. 11, 2019, 4:48 a.m. UTC
> > +    (arguments
> > +     `(#:tests? #f  ; no "check" target
> > +       #:make-flags
> > +       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> > +       #:phases
> > +       (modify-phases %standard-phases
> > +         (add-after 'unpack 'skip-dssi-binaries
> > +           (lambda _
> > +             (substitute* "Makefile"
> > +                          (("cp -r bin.*-dssi.*$") ":;\n"))
> > +             #t))
> 
> Can you expand on this comment?  What are these binaries, and why do
> we
> need to prevent them from being installed?
I was having trouble building them, but I managed to get them building
now (was missing liblo). Removed this part

> 
> > +    (license `(license:isc license:gpl3 license:lgpl3 license:mit 
> > license:gpl2))))
> 
> Does this work?  I would expect each of the license entries to have
> to
> be 'unquoted', i.e. `(,license:isc).  Alternatively you can use (list
> ...) here.
> 
> When a package has multiple licenses like here, please add a comment
> about it.  Is there a "main" license, (roughly) which files are under
> what license?
Fixed and added more info

Comments

Marius Bakke Nov. 13, 2019, 10:30 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> From 065b91fd765d8df510bcf969c9f41ae792733632 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 08:55:22 +0000
> Subject: [PATCH] gnu: Add dpf-plugins.
>
> * gnu/packages/music.scm: (dpf-plugins): New variable.

Applied, thanks!
diff mbox series

Patch

From 065b91fd765d8df510bcf969c9f41ae792733632 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 08:55:22 +0000
Subject: [PATCH] gnu: Add dpf-plugins.

* gnu/packages/music.scm: (dpf-plugins): New variable.
---
 gnu/packages/music.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..784462e56d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,51 @@  for integration into status line generators or other command-line tools.")
 effects.  It contains a bitcrusher, delay, distortion, equalizer, compressor,
 and reverb.")
     (license license:gpl2+)))
+
+(define-public dpf-plugins
+  (package
+    (name "dpf-plugins")
+    (version "1.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/DISTRHO/DPF-Plugins.git")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1hsfmpv3kvpiwk8nfw9xpaipzy0n27i83y2v1yr93lznwm5rqrbs"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _ (setenv "CC" "gcc") #t))
+             (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("liblo" ,liblo)  ; for dssi plugins
+       ("jack" ,jack-1)  ; for standalone applications
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("dssi" ,dssi)
+       ("lv2" ,lv2)))
+    (home-page "https://github.com/DISTRHO/DPF-Plugins")
+    (synopsis "Audio plugin collection")
+    (description "Collection of audio plugins built with the DISTRHO Plugin
+Framework (DPF) available in LADSPA, DSSI, LV2 and VST2 formats.  This
+package includes the following plugins: glBars, Kars, Max-Gen examples
+(MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift), Mini-Series (3BandEQ,
+3BandSplitter, PingPongPan), ndc-Plugs (Amplitude Imposer, Cycle Shifter,
+Soul Force), MVerb, Nekobi, and ProM.")
+    ;; This package consists of several plugins refactored to use the
+    ;; DISTHRO Plugin Framework (DPF). Different copyrights and licenses
+    ;; apply to different plugins. The root LICENSE file has a table with
+    ;; license information for each plugin and paths to each license
+    (license (list license:isc license:gpl3 license:lgpl3 license:expat license:gpl2))))
-- 
2.24.0