diff mbox series

[bug#67399] gnu: aflplusplus: Add python support

Message ID 5e850cca0eca17b210575bd38de5bbbdc0430eca.1693578094.git.GNUtoo@cyberdimension.org
State New
Headers show
Series [bug#67399] gnu: aflplusplus: Add python support | expand

Commit Message

Denis 'GNUtoo' Carikli Nov. 23, 2023, 2:52 p.m. UTC
* gnu/packages/debug.scm (aflplusplus): [inputs]: Add python.
---
 gnu/packages/debug.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)


base-commit: 4e531e55dcdc99c83bcfe3eec67c3fd95c7b6ca7
prerequisite-patch-id: 529f1c3b53aec479891730e8b6e21f6a59cd7c71
prerequisite-patch-id: 6f0e10ac9b56f321f690b28d50f7bde94b8c3933
prerequisite-patch-id: c27dc1855d1350c395cd0f5788b57ee6be532328
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 31f59f02f8..b6d84495e4 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -479,7 +479,9 @@  (define-public aflplusplus
     ;; aflplusplus source code has the following comment: "GCC 12 is producing
     ;; compile errors for some targets so we stay at GCC 11", however with
     ;; Guix GCC 12 seems to work fine so far.
-    (inputs (list gcc gmp qemu))
+    ;; The python input is needed to support writing custom mutations in
+    ;; python.
+    (inputs (list gcc gmp python qemu))
     (home-page "https://aflplus.plus")
     (description
      "AFLplusplus is a security-oriented fuzzer that employs a novel type of