diff mbox series

[bug#38351] gnome-characters

Message ID 5e448abe005d25a6c831e20b54cbff6f0610ec63.camel@disroot.org
State Accepted
Headers show
Series [bug#38351] gnome-characters | expand

Commit Message

Raghav Gururajan Nov. 23, 2019, 6:56 p.m. UTC
Hello Guix!

Please find the attached file containing patch to add gnome-characters.

Thank you!

Regards,
RG.
diff mbox series

Patch

From a4c360090b6d71c73619c7585bbb157b7b33f4b7 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 23 Nov 2019 13:34:47 -0500
Subject: [PATCH 2/3] gnu: Add gnome-characters.

* gnu/packages/gnome.scm (gnome-characters): New Variable.
---
 0001-Add-gnome-contacts.patch | 81 +++++++++++++++++++++++++++++++++++
 gnu/packages/gnome.scm        | 28 ++++++++++++
 2 files changed, 109 insertions(+)
 create mode 100644 0001-Add-gnome-contacts.patch

diff --git a/0001-Add-gnome-contacts.patch b/0001-Add-gnome-contacts.patch
new file mode 100644
index 0000000000..01380265e8
--- /dev/null
+++ b/0001-Add-gnome-contacts.patch
@@ -0,0 +1,81 @@ 
+From 1ea14a09d76e7be1eda9282dafb6ea57b18eae74 Mon Sep 17 00:00:00 2001
+From: Raghav Gururajan <raghavgururajan@disroot.org>
+Date: Sat, 23 Nov 2019 11:11:29 -0500
+Subject: [PATCH] Add gnome-contacts.
+
+---
+ gnu/packages/gnome.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 51 insertions(+)
+
+diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
+index cd881b5b87..bbec7eabca 100644
+--- a/gnu/packages/gnome.scm
++++ b/gnu/packages/gnome.scm
+@@ -42,6 +42,7 @@
+ ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+ ;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+ ;;; Copyright © 2019 David Wilson <david@daviwil.com>
++;;; Copyright © 2019 Raghav Gururajan <raghavgururajan@disroot.org>
+ ;;;
+ ;;; This file is part of GNU Guix.
+ ;;;
+@@ -468,6 +469,56 @@ can be used to configure a source directory checked out from Git and some
+ commonly used macros.")
+     (license license:gpl2+)))
+ 
++(define-public gnome-contacts
++  (package
++    (name "gnome-contacts")
++    (version "3.30.2")
++    (source (origin
++	      (method url-fetch)
++	      (uri (string-append "mirror://gnome/sources/" name "/"
++				  (version-major+minor version) "/"
++				  name "-" version ".tar.xz"))
++	      (sha256
++	       (base32 
++		"1b0pkdwz9yqcv82zzdf76rs2w3wa5zli8pka09wnahikx1ykk43h"))))
++    (build-system meson-build-system)
++    (arguments
++      `(#:phases
++        (modify-phases %standard-phases
++          (add-after 'unpack 'generate-vapis
++            (lambda* (#:key inputs #:allow-other-keys)
++              (invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
++                      "--library=goa-1.0"
++                      (string-append (assoc-ref inputs "gnome-online-accounts:lib")
++                                     "/share/gir-1.0/Goa-1.0.gir"))
++              #t)))))
++    (native-inputs
++     `(("pkg-config" ,pkg-config)
++       ("vala" ,vala)
++       ("glib:bin" ,glib "bin")
++       ("gobject-introspection" ,gobject-introspection)
++       ("libgee" ,libgee)
++       ("evolution-data-server" ,evolution-data-server)
++       ("gnome-desktop" ,gnome-desktop)
++       ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
++       ("cheese" ,cheese)
++       ("gst-plugins-base" ,gst-plugins-base)
++       ("telepathy-glib" ,telepathy-glib)
++       ("gettext" ,gettext-minimal)
++       ("libxslt" ,libxslt)
++       ("docbook-xml" ,docbook-xml)
++       ("dockbook-xsl" ,docbook-xsl)
++       ("gtk+" ,gtk+)
++       ("gtk+:bin" ,gtk+ "bin")))
++    (propagated-inputs
++     `(("folks", folks)
++       ("telepathy-mission-control" ,telepathy-mission-control)))
++    (synopsis "Contacts is GNOME's integrated address book.")
++    (description "It is written in Vala and uses 
++		 libfolks (also written in Vala) and Evolution Data Server.")
++    (home-page "https://wiki.gnome.org/Apps/Contacts")
++    (license gpl2))
++
+ (define-public gnome-desktop
+   (package
+     (name "gnome-desktop")
+-- 
+2.24.0
+
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bbec7eabca..d1c4a43f07 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -447,6 +447,34 @@  documents.  This package also contains binaries that can convert XPS documents
 to other formats.")
     (license license:lgpl2.1+)))
 
+(define-public gnome-characters ;; not gucharmap
+  (package
+    (name "gnome-characters") ;; not gucharmap
+    (version "3.30.0")
+    (source (origin
+	      (method url-fetch)
+	      (uri (string-append "mirror://gnome/sources/" name "/"
+				  (version-major+minor version) "/"
+				  name "-" version ".tar.xz"))
+	      (sha256
+	       (base32 
+		"08cwz39iwgsyyb2wqhb8vfbmh1cwfkgfiy7adp08w7rwqi99x3dp"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("libunistring" ,libunistring)
+       ("pkg-config" ,pkg-config)
+       ("gjs" ,gjs)
+       ("gtk+" ,gtk+)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")))
+    (synopsis "GNOME Characters")
+    (description "Characters is a simple utility application to find and 
+		 insert unusual characters. It allows you to quickly find 
+		 the character you are looking for by searching for keywords.")
+    (home-page "https://wiki.gnome.org/Design/Apps/CharacterMap")
+    (license bsd-3))
+
 (define-public gnome-common
   (package
     (name "gnome-common")
-- 
2.24.0