diff mbox series

[bug#70971,v2,1/3] gnu: dhewm3: Use git repository.

Message ID 5e1af945c5118711bf3d16d10eb0df91d1841cbc.1717739144.git.jsubuntuxp@disroot.org
State New
Headers show
Series Update dhewm3 | expand

Commit Message

James Smith June 7, 2024, 5:45 a.m. UTC
* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
instead of downloading a tarball from GitHub.

Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
---
 gnu/packages/game-development.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

Comments

Christopher Baines June 11, 2024, 10:38 a.m. UTC | #1
James Smith via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
> instead of downloading a tarball from GitHub.
>
> Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
> ---
>  gnu/packages/game-development.scm | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)

I'm missing why you're making this change? I don't see anything wrong
with using these upstream release tarballs.
James Smith June 11, 2024, 12:45 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

> James Smith via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
>> instead of downloading a tarball from GitHub.
>>
>> Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
>> ---
>>  gnu/packages/game-development.scm | 12 ++++++------
>>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> I'm missing why you're making this change? I don't see anything wrong
> with using these upstream release tarballs.

I noticed that the package was using a tarball from GitHub and assumed
that it was one that was autogenerated. Upon closer inspection, I see
that it's a manually pack tarball instead. I can send a new set of
patches that excludes switching to the git repository if needed.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5b7852c4eb..89ace2925b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -22,7 +22,7 @@ 
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
-;;; Copyright © 2020-2022 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020-2022, 2024 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
@@ -3101,13 +3101,13 @@  (define-public dhewm3
     (name "dhewm3")
     (version "1.5.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/dhewm/dhewm3/releases/download/"
-                    version "/dhewm3-" version "-src.tar.xz"))
+              (method git-fetch)
+              (uri (git-reference (url "https://github.com/dhewm/dhewm3")
+                                  (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "10p0w1x5wx9b7d8mzvb6yqjia9prhkjwz04vbvphy8p383r33am6"))))
+                "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; No tests.