diff mbox series

[bug#74497,05/46] gnu: Add python-hasasia.

Message ID 5deb35996e429871b36feaa484bc4f08502a24ca.1732384228.git.sharlatanus@gmail.com
State New
Headers show
Series Astro update 2024/11. | expand

Commit Message

Sharlatan Hellseher Nov. 23, 2024, 7:50 p.m. UTC
* gnu/packages/astronomy.scm (python-hasasia): New variable.

Change-Id: Iaf6df32037b9435da2731c080578042f1f03867c
---
 gnu/packages/astronomy.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc34cb7c40..cac446a6a3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2447,6 +2447,43 @@  (define-public python-halotools
 from a cosmological simulation.")
     (license license:bsd-3)))
 
+(define-public python-hasasia
+  (package
+    (name "python-hasasia")
+    (version "1.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hasasia" version))
+       (sha256
+        (base32 "0vs3935c9cqwp44dycxfsv4p9q4zbw8i5z3946928yy0nqmj1aw7"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest
+           python-setuptools
+           python-wheel))
+    (propagated-inputs
+     (list python-astropy
+           python-numpy
+           python-scipy))
+    (home-page "https://github.com/Hazboun6/hasasia")
+    (synopsis "Pulsar timing array sensitivity curves calculation in Python")
+    (description
+     "This package provides a Python package to calculate gravitational-wave
+sensitivity curves for pulsar timing arrays.
+
+Features:
+@itemize
+@item pulsar transmission functions
+@item inverse-noise-weighted transmission functions
+@item individual pulsar sensitivity curves
+@item pulsar timing array sensitivity curves as characteristic strain, strain
+sensitivity or energy density
+@item power-law integrated sensitivity curves
+@item sensitivity sky maps for pulsar timing arrays
+@end itemize")
+    (license license:expat)))
+
 (define-public python-healpy
   (package
     (name "python-healpy")