diff mbox series

[bug#65681,2/2] gnu: simh: Use G-Expressions.

Message ID 5dcaf8f1d76f5ebac8dfd128c4ad5b465898caa4.1693579858.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65681,1/2] gnu: simh: Update to 3.12-4. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Sept. 1, 2023, 2:53 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/simh.scm (simh)[arguments]: Convert to list of G-Expressions.
---
 gnu/packages/simh.scm | 70 +++++++++++++++++++++----------------------
 1 file changed, 35 insertions(+), 35 deletions(-)

Comments

Maxim Cournoyer Sept. 6, 2023, 12:51 a.m. UTC | #1
Hi,

Series installed :-).
diff mbox series

Patch

diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 2cf92516ba..9f5c04d8fb 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -19,6 +19,7 @@ 
 
 (define-module (gnu packages simh)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -48,41 +49,40 @@  (define-public simh
     (inputs
      (list libpcap))
     (arguments
-     `(#:tests? #f
-       #:make-flags (list
-                     (string-append "GCC=" ,(cc-for-target) " -fcommon"))
-       #:modules ((ice-9 string-fun)
-                  ,@%gnu-build-system-modules)
-       #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)
-           (add-before 'build 'prepare-build
-             (lambda _
-               (substitute* "makefile"
-                 (("LIBPATH:=/usr/lib")
-                  (string-append "LIBPATH:="
-                                 (string-replace-substring
-                                  (getenv "LIBRARY_PATH") ":" " ")))
-                 (("export LIBRARY_PATH = .*") ""))
-               (mkdir "BIN")))
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin/"))
-                      (lib (string-append out "/lib/simh/")))
-                 (mkdir-p bin)
-                 (mkdir-p lib)
-                 (for-each
-                   (lambda (file)
-                     (copy-file file (string-append bin
-                                                    "simh-"
-                                                    (basename file))))
-                   (find-files "BIN"))
-                 (for-each
-                   (lambda (file)
-                     (copy-file file (string-append lib
-                                                    (basename file))))
-                   (find-files "VAX" "bin$"))))))))
+     (list #:tests? #f
+           #:make-flags
+           #~(list (string-append "GCC=" #$(cc-for-target) " -fcommon"))
+           #:modules `((ice-9 string-fun)
+                       ,@%gnu-build-system-modules)
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (add-before 'build 'prepare-build
+                 (lambda _
+                   (substitute* "makefile"
+                     (("LIBPATH:=/usr/lib")
+                      (string-append "LIBPATH:="
+                                     (string-replace-substring
+                                      (getenv "LIBRARY_PATH") ":" " ")))
+                     (("export LIBRARY_PATH = .*") ""))
+                   (mkdir "BIN")))
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin/"))
+                          (lib (string-append out "/lib/simh/")))
+                     (mkdir-p bin)
+                     (mkdir-p lib)
+                     (for-each (lambda (file)
+                                 (copy-file file
+                                            (string-append bin "simh-"
+                                                           (basename file))))
+                               (find-files "BIN"))
+                     (for-each (lambda (file)
+                                 (copy-file file
+                                            (string-append lib
+                                                           (basename file))))
+                               (find-files "VAX" "bin$"))))))))
     (home-page "http://simh.trailing-edge.com")
     (synopsis "Collection of simulators from The Computer History Simulation
 Project")