diff mbox series

[bug#39201] gnu: Add r-deconstructsigs.

Message ID 5d8aa06a6dd9845acfab5685b4106e7c382a7887.camel@gnu.org
State Accepted
Headers show
Series [bug#39201] gnu: Add r-deconstructsigs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen Jan. 20, 2020, 12:18 p.m. UTC
Dear Guix,

Here's a patch to add r-deconstructsigs.  I added it to the cran module
because that's where it originates from, but it takes a reference
genome from bioconductor.  So I had to use the bioconductor module.  Is
that OK?

Thanks for your hard work and valuable time.

Kind regards,
Roel Janssen

Comments

Ricardo Wurmus Jan. 20, 2020, 1:16 p.m. UTC | #1
Hi Roel,

> Here's a patch to add r-deconstructsigs.  I added it to the cran module
> because that's where it originates from, but it takes a reference
> genome from bioconductor.  So I had to use the bioconductor module.  Is
> that OK?

Please add the package to the bioconductor module instead and add a
comment above to explain why.  (That’s what we’ve done for other
packages like this.)

--
Ricardo
diff mbox series

Patch

From e2a436698e81ce6b70be982a2193e6307606be41 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 20 Jan 2020 13:14:52 +0100
Subject: [PATCH] gnu: Add r-deconstructsigs.

* gnu/packages/cran.scm (r-deconstructsigs): New variable.
---
 gnu/packages/cran.scm | 29 ++++++++++++++++++++++++++++-
 1 file changed, 28 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ff2490bc31..f4ecb9dec7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2,7 +2,7 @@ 
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
@@ -43,6 +43,7 @@ 
   #:use-module (guix build-system r)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bioconductor)
   #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages c)
   #:use-module (gnu packages compression)
@@ -1911,6 +1912,32 @@  instructed to explore various modifications of the objects (e.g., sorting
 rows, dropping names) to see if the modified versions are identical.")
     (license license:gpl2+)))
 
+(define-public r-deconstructsigs
+  (package
+    (name "r-deconstructsigs")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "deconstructSigs" version))
+              (sha256
+               (base32
+                "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+    (properties
+     `((upstream-name . "deconstructSigs")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bsgenome" ,r-bsgenome)
+       ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-reshape2" ,r-reshape2)))
+    (home-page "https://github.com/raerose01/deconstructSigs")
+    (synopsis "Identifies signatures present in a tumor sample")
+    (description "This package takes sample information in the form of the
+fraction of mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed, most
+closely reconstructs the mutational profile.")
+    (license license:gpl2+)))
+
 (define-public r-dendextend
   (package
     (name "r-dendextend")
-- 
2.17.1