diff mbox series

[bug#38141] gnu: Add carla.

Message ID 5d54f57ec6e1b265d8c3bf9f1790f8aad5bc32f6.camel@zrythm.org
State Accepted
Headers show
Series [bug#38141] gnu: Add carla. | expand

Commit Message

Alexandros Theodotou Nov. 16, 2019, 9:35 p.m. UTC
Hi Marius,

> Can you build with '--keep-failed', and then run:
> 
>   diffoscope /gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-
> 2.0.0{,-check}
> 
> and send the output?
> 
> The updated patch LGTM, but does not apply any more.  Can you rebase
> it
> on top of current 'master'?

Attaching the diffoscope output and updated patch. The output from
diffoscope was 8.5MB so I compressed it. Note that the hash has
changed.

Comments

Marius Bakke Nov. 19, 2019, 11:17 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi Marius,
>
>> Can you build with '--keep-failed', and then run:
>> 
>>   diffoscope /gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-
>> 2.0.0{,-check}
>> 
>> and send the output?
>> 
>> The updated patch LGTM, but does not apply any more.  Can you rebase
>> it
>> on top of current 'master'?
>
> Attaching the diffoscope output and updated patch. The output from
> diffoscope was 8.5MB so I compressed it. Note that the hash has
> changed.

Thanks.  So it looks like resources_rc.py is not reproducible.  It is
not really possible to tell why from the diffoscope output though.

It is generated by PyQt, so I opened a separate bug report about it:

https://bugs.gnu.org/38283

[...]

> From 879230335a8ef5b40d09f493f380ab310c6976b3 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 23:56:58 +0000
> Subject: [PATCH] gnu: Add carla.
>
> * gnu/packages/audio.scm (carla): New variable.

Applied (with indentation change), thanks!
diff mbox series

Patch

From 879230335a8ef5b40d09f493f380ab310c6976b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 23:56:58 +0000
Subject: [PATCH] gnu: Add carla.

* gnu/packages/audio.scm (carla): New variable.
---
 gnu/packages/audio.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d59b4eb87e..453fa7581f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3811,3 +3811,59 @@  therefore satisfying any requirements they may have to be self contained,
 as is the case with audio plugins.")
     (home-page "https://gitlab.com/geontime/redkite")
     (license license:gpl3+)))
+
+(define-public carla
+  (package
+    (name "carla")
+    (version "2.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/falkTX/Carla.git")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable-and-show-features
+           (lambda _
+             (setenv "CC" "gcc")
+             (invoke "make" "features")))
+         (delete 'configure))))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("ffmpeg" ,ffmpeg)
+       ("fluidsynth" ,fluidsynth)
+       ("file" ,file)
+       ("liblo" ,liblo)
+       ("libsndfile" ,libsndfile)
+       ("gtk+" ,gtk+)
+       ("python-pyliblo" ,python-pyliblo)
+       ("python-pyqt" ,python-pyqt)
+       ("python-rdflib" ,python-rdflib)
+       ;; python-pyqt shows the following error without python-wrapper:
+       ;; Error while finding module specification for 'PyQt5.uic.pyuic'
+       ;; (ModuleNotFoundError: No module named 'PyQt5')
+       ("python-wrapper" ,python-wrapper)
+       ("libx11" ,libx11)
+       ("qtbase" ,qtbase)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://kx.studio/Applications:Carla")
+    (synopsis "Audio plugin host")
+    (description "Carla is a modular audio plugin host, with features like
+transport control, automation of parameters via MIDI CC and remote control
+over OSC.  Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
+and VST3 plugin formats, plus SF2 and SFZ file support.  It uses JACK as the
+default and preferred audio driver but also supports native drivers like ALSA.")
+    (license license:gpl2+)))
-- 
2.24.0