diff mbox series

[bug#39213] fogpad: reverb plugin

Message ID 5d2292f1a686c3b66444e6903850f534224f37ec.camel@zrythm.org
State Accepted
Headers show
Series [bug#39213] fogpad: reverb plugin | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Jan. 21, 2020, 5:41 a.m. UTC
This is another plugin by the same upstream. Should be merged after
regrader.

Thanks,
Alex
diff mbox series

Patch

From 423212a59053de99e87eb9e4a90e971f60c3230d Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 21 Jan 2020 05:37:39 +0000
Subject: [PATCH 2/2] gnu: Add fogpad.

* gnu/packages/music.scm (fogpad): New variable.
---
 gnu/packages/music.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 90774eafe7..f5dbbd65b2 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,29 @@  This is an unofficial port of the Regrader plugin created by Igorski.  It
 is available as an LV2 plugin, a VST plugin and a standalone JACK
 application.")
     (license license:expat)))
+
+(define-public fogpad
+  (package
+    (inherit vl1-emulator)
+    (name "fogpad")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/fogpad")
+               (commit (string-append "v" version))
+               ;; bundles a specific commit of the DISTRHO plugin framework
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1j1hbya2dsqpf22zkpi4kwz3dram9g1ndxzmgfwpmf3i4jd3csgb"))))
+    (home-page "https://github.com/linuxmao-org/fogpad")
+    (synopsis "Reverb effect plugin")
+    (description
+     "Fogpad is a reverb effect in which the reflections can be frozen,
+filtered, pitch shifted and ultimately disintegrated.  This is an unofficial
+port of the Regrader plugin created by Igorski.  It is available as an LV2
+plugin, a VST plugin and a standalone JACK application.")
+    (license license:expat)))
-- 
2.24.1