diff mbox series

[bug#50035,1/3] gnu: go-github-com-godbus-dbus: Update to 5.0.4.

Message ID 5d1fcc896c0f6f63e1664f0eadabf73f0965110b.1628823527.git.iskarian@mgsn.dev
State New
Headers show
Series [bug#50035,1/3] gnu: go-github-com-godbus-dbus: Update to 5.0.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 13, 2021, 3:06 a.m. UTC
* gnu/packages/golang.scm (go-github-com-godbus-dbus): Update to 5.0.4.
---
While I was updating this, I renamed it to match the proper import path (so
the Go importer sees this package), and fixed those pesky D-Bus tests.

--
Sarah
 gnu/packages/golang.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: d87d6d68128c53a95fe09c3a4381575646c0f368

Comments

John Kehayias Aug. 13, 2021, 7:12 p.m. UTC | #1
I was just working on another package that needs the current version of godbus-dbus, so thanks for this patch. I haven't yet built your version, but previously I had to disable tests that it looks like you fixed, great!
John Kehayias Feb. 4, 2022, 8:06 p.m. UTC | #2
Hello,

I recently built this with these changes and updating to version 5.0.6 with hash 0d7740bjprd6mhs1wmhd53fb3kf61dz0hp1a0dda3dc28w2z84pp Builds successfully and works for a package I'm working on.

I'm not sure how much of a "review" this counts for exactly, but would be great to have this revived and pushed.

Thanks!
John
John Kehayias Oct. 12, 2023, 5:53 p.m. UTC | #3
Hi Ludo’ and Nguyễn (and cc'ing Sarah from earlier patches),

On Fri, Oct 13, 2023 at 01:16 AM, Nguyễn Gia Phong wrote:

> On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
>> <https://qa.guix.gnu.org/issue/64222> was inconclusive
>> (for some reason it had not built all the dependents)
>
> qa.guix.gnu.org was briefly broken at the time IIRC,
> happened to other adjacent patchsets.
>
> On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
>> so I checked locally and the go-github-com-godbus-dbus upgrade
>> does not introduce new breakage.
>>

I haven't checked but this might need some fixing as based on an earlier
patch for updating godbus (I can't help but read this as "god bus") the
import name has changed. Though as an example chezmoi seems to have been
broken for some time anyway. Maybe the import-name doesn't need the v5?

See

<https://issues.guix.gnu.org/50035>

and

<https://issues.guix.gnu.org/50037>.

The earlier patch also has fixes for the tests which would be good to
include now.

My apologies to Sarah as my original replies way back when only went to
the bug number (we should document this, easy beginner mistake!) and
once I became a committer this was on my list to update and push but I
didn't get around to it.

Nguyễn and/or Sarah would you like to submit a patch to change the
import path if needed, enable tests, and make any other changes? I could
also take a look if no one gets to it quickly.

>> I wrapped the long ‘description’ lines, removed ‘Signed-off-by’ tags
>> from the logs (they’re for committers), and committed.
>
> Thanks a lot!

Thanks to all on this updates!

John

PS: Looks like one extra signed-off-by tag made it through on a commit.
Oh well, glad I'm not the only one who's not perfect at these things!
dziltener--- via Guix-patches via Oct. 13, 2023, 4:52 a.m. UTC | #4
On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
> [godbus's] import name has changed.  Though as an example
> chezmoi seems to have been broken for some time anyway.
> Maybe the import-name doesn't need the v5?

IIUC go-github-com-godbus-dbus is just a name for human consumption,
on the other hand I don't understand how it works without
the import-path matching the one in the go.mod file:

On 2021-08-13 at 20:49-07:00, Sarah Morgensen wrote in patchset 50037:
> -     `(#:import-path "github.com/godbus/dbus"
> +     `(#:import-path "github.com/godbus/dbus/v5"

On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
> Nguyễn and/or Sarah would you like to submit a patch to change the
> import path if needed, enable tests, and make any other changes? I could
> also take a look if no one gets to it quickly.

As stated above, I don't quite understand how go packages work
(when they don't seem to be supposed to), so you two please go ahead.
(BTW you can call me by my given name Phong.)

On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
> I can't help but read this as "god bus"

Yea DBus is short for Dieu Bus anyway.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f4cd30c662..15826514bc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7424,7 +7424,7 @@  and @code{ioutil} packages that is easy to test.")
 (define-public go-github-com-godbus-dbus
   (package
     (name "go-github-com-godbus-dbus")
-    (version "5.0.3")
+    (version "5.0.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -7433,7 +7433,7 @@  and @code{ioutil} packages that is easy to test.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1bkc904073k807yxg6mvqaxrr6ammmhginr9p54jfb55mz3hfw3s"))))
+                "0znax8kskb5gmp5fj75w56bc9p7b22wrdswzlh4d04sprlc471yi"))))
     (build-system go-build-system)
     (arguments
      `(#:tests? #f ;no /var/run/dbus/system_bus_socket