diff mbox series

[bug#70684,go-team,4/6] gnu: Add go-github-com-abadojack-whatlanggo and go-github-com-fxamacker-cbor-v2.

Message ID 5cf8e58563592213d679e9e379dd1648d7684c2e.1714508305.git.rodion.goritskov@gmail.com
State New
Headers show
Series Update miniflux to 2.1.3 | expand

Commit Message

Rodion Goritskov April 30, 2024, 8:42 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-abadojack-whatlanggo): New variable.
* gnu/packages/golang-xyz.scm (go-github-com-fxamacker-cbor-v2): New variable.

Change-Id: I85c544262f01f274e54d70526b9dfc79af2a11c7
---
 gnu/packages/golang-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f4ec142949..ef733ba3bc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -81,6 +81,31 @@  (define-public go-github-com-a8m-envsubst
 substitution.")
     (license license:expat)))
 
+(define-public go-github-com-abadojack-whatlanggo
+  (package
+    (name "go-github-com-abadojack-whatlanggo")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/abadojack/whatlanggo")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pidd5dqvcnqjjka12h0clj3mmq0j3bpanf9153schsx85xz7mzx"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/abadojack/whatlanggo"))
+    (home-page "https://github.com/abadojack/whatlanggo")
+    (synopsis "Natural language detection library for Go")
+    (description
+     "Package detects natural languages and scripts (writing systems).
+Languages are represented by a determined list of constants
+while scripts are represented by RangeTable.")
+    (license license:expat)))
+
 (define-public go-github-com-alecthomas-chroma
   (package
     (name "go-github-com-alecthomas-chroma")
@@ -635,6 +660,31 @@  (define-public go-github-com-elliotchance-orderedmap
 for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
     (license license:expat)))
 
+(define-public go-github-com-fxamacker-cbor-v2
+  (package
+    (name "go-github-com-fxamacker-cbor-v2")
+    (version "2.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fxamacker/cbor")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "092g48d0mb7mv09x4qb3s899haliar8m7cvv77s5cqc5rncj6hzh"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/fxamacker/cbor/v2"))
+    (propagated-inputs (list go-github-com-x448-float16))
+    (home-page "https://github.com/fxamacker/cbor")
+    (synopsis "CBOR Codec in Go")
+    (description
+     "This is a Go library for encoding and decoding CBOR and CBOR Sequences,
+with CBOR tags, Go struct tags (toarray, keyasint, omitempty), float64/32/16, big.Int")
+    (license license:expat)))
+
 (define-public go-github-com-gabriel-vasile-mimetype
   (package
     (name "go-github-com-gabriel-vasile-mimetype")