diff mbox series

[bug#66530] gnu: Add r-metacell.

Message ID 5cf244a75edf748f180e87b4607a67126260115f.1697213683.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#66530] gnu: Add r-metacell. | expand

Commit Message

nafkhamdc Oct. 13, 2023, 4:14 p.m. UTC
* gnu/packages/bioinformatics.scm (r-metacell): New variable.
---
 gnu/packages/bioinformatics.scm | 60 +++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)


base-commit: dcfd4d9c4827ca6bfebeec46fe6bb8373c425a1c
prerequisite-patch-id: 8b3f1b30e7ca1f6ddb21bf801faad91cce276dfd
prerequisite-patch-id: 86f04eb38885c80e1fa302cec734581778e62c26
prerequisite-patch-id: d5cebe9646097c611915c8b796a94ff0d1831343
prerequisite-patch-id: 675ed63512dcf5b145a929d0097b1bb7e7f1c389
prerequisite-patch-id: 8a7046dfe2c6c18892fed37a877f66be5be7f96e

Comments

Ricardo Wurmus Oct. 17, 2023, 12:33 p.m. UTC | #1
Thanks for the patches.  I applied them after some massaging.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb0bdf766e..45afde699d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10285,6 +10285,66 @@  (define-public r-markdownreports
 discovered.")
       (license license:gpl3))))
 
+(define-public r-metacell
+  (let ((commit "d6a6926d103ee0cb34a611c753572429c94a53d9")
+        (revision "1"))
+    (package
+      (name "r-metacell")
+      (version (git-version "0.3.41" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tanaylab/metacell/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zrsckr3y35x37mj3ibm6scyqx925s84wzrz1i42fnm9n3msc265"))))
+      (properties `((upstream-name . "metacell")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-cluster
+                               r-cowplot
+                               r-data-table
+                               r-dbscan
+                               r-domc
+                               r-dplyr
+                               r-entropy
+                               r-ggplot2
+                               r-graph
+                               r-igraph
+                               r-kernsmooth
+                               r-magrittr
+                               r-matrix
+                               r-matrixstats
+                               r-pdist
+                               r-pheatmap
+                               r-plyr
+                               r-rcolorbrewer
+                               r-rcurl
+                               r-rgraphviz
+                               r-slam
+                               r-singlecellexperiment
+                               r-svglite
+                               r-tgconfig
+                               r-tgstat
+                               r-tgutil
+                               r-tidyr
+                               r-umap
+                               r-umap
+                               r-zoo))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/tanaylab/metacell/")
+      (synopsis "Meta cell analysis for single cell RNA-seq data")
+      (description
+       "This package facilitates the analysis of single-cell RNA-seq UMI matrices.
+It does this by computing partitions of a cell similarity graph into
+small homogeneous groups of cells, which are defined as metacells (MCs).
+The derived MCs are then used for building different representations of
+the data, allowing matrix or 2D graph visualization forming a basis for
+analysis of cell types, subtypes, transcriptional gradients,cell-cycle
+variation, gene modules and their regulatory models and more.")
+      (license license:expat))))
+
 (define-public r-snapatac
   (package
     (name "r-snapatac")