diff mbox series

[bug#67309,gnome-team,2/2] gnu: Add gnome-connections.

Message ID 5ce27f5a5cd0cf93561e542103426cf39b2b9a1b.1700508505.git.vivien@planete-kraus.eu
State New
Headers show
Series Add gnome-connections | expand

Commit Message

Vivien Kraus Nov. 20, 2023, 7:25 p.m. UTC
* gnu/packages/gnome.scm (gnome-connections): New variable.

Change-Id: I4c026ab3aae07a73fcbc9b4b0612538455fe126a
---
 gnu/packages/gnome.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

Comments

Liliana Marie Prikler Nov. 20, 2023, 7:55 p.m. UTC | #1
Am Montag, dem 20.11.2023 um 20:25 +0100 schrieb Vivien Kraus:
> * gnu/packages/gnome.scm (gnome-connections): New variable.
> 
> Change-Id: I4c026ab3aae07a73fcbc9b4b0612538455fe126a
> ---
>  gnu/packages/gnome.scm | 58
> ++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 58 insertions(+)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 6ace6d2f90..90090b11bc 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -13621,3 +13621,61 @@ (define-public gtk-frdp
>  This library provides a widget to view @acronym{RDP,Remote Desktop
> Protocol}
>  sessions.")
>      (license license:gpl3+)))
> +
> +(define-public gnome-connections
> +  (package
> +    (name "gnome-connections")
> +    (version "44.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "mirror://gnome/sources/" name "/"
> +                                  (version-major version) "/"
> +                                  name "-" version ".tar.xz"))
> +              (sha256
> +               (base32
> +               
> "0sv238bq0dhi68ksr3bcl4q44i3ishk5i10c2325qz879f92sshk"))
> +              (snippet
> +               #~(begin
> +                   (use-modules (guix build utils))
> +                   (delete-file-recursively "subprojects")))))
> +    (build-system meson-build-system)
> +    (arguments
> +     (list
> +      #:glib-or-gtk? #t
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'patch-meson
> +            (lambda _
> +              (substitute* "meson.build"
> +                (("gtk_update_icon_cache: true")
> +                 "gtk_update_icon_cache: false")
> +                (("update_desktop_database: true")
> +                 "update_desktop_database: false"))))
> +          (add-after 'unpack 'disable-nonfree-advertisement
> +            (lambda _
> +              (substitute* "src/ui/assistant.ui"
> +                (("\\(standard for connecting to Windows\\)")
> +                 "")
I'm not sure whether deleting this makes sense.  We have a similar
information/warning in the disk formatter regarding NTFS :)
> +                (("\\(standard for connecting to Linux\\)")
> +                 "(standard for connecting to GNU/Linux)"))
> +              (substitute* "src/ui/onboarding-dialog.ui"
> +                (("Access Linux, Mac, and Windows")
> +                 "Access many different")
Use a regexp here.
> +                (("multiplatform.svg")
> +                 "welcome.svg")))))))
What's the visual diff between the two?
> +    (inputs
> +     (list gtk+ gtk-frdp gtk-vnc libhandy libsecret libxml2))
> +    (native-inputs
> +     (list gettext-minimal
> +           `(,glib "bin")
> +           itstool
> +           pkg-config
> +           vala))
> +    (home-page "https://apps.gnome.org/Connections")
> +    (synopsis "View and use other desktops")
> +    (description "\
> +Connections allows the user to connect to different machines or
> virtual
If possible, don't use these "smart" non-line-breaks.  Just write your
description as is.
> +machines.
"Machines or virtual machines" reads a little weird imho.
>   It can be used to provide support to users who might need help.
This sentence is a bit gratutious imho.  Deleting it also allows you to
merge the previous and the next with an appropriate connector.
>   It
> +can use @acronym{VNC,Virtual Network Computing} and
> @acronym{RDP,Remote
> +Desktop Protocol}.")
> +    (license license:gpl3+)))

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6ace6d2f90..90090b11bc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13621,3 +13621,61 @@  (define-public gtk-frdp
 This library provides a widget to view @acronym{RDP,Remote Desktop Protocol}
 sessions.")
     (license license:gpl3+)))
+
+(define-public gnome-connections
+  (package
+    (name "gnome-connections")
+    (version "44.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0sv238bq0dhi68ksr3bcl4q44i3ishk5i10c2325qz879f92sshk"))
+              (snippet
+               #~(begin
+                   (use-modules (guix build utils))
+                   (delete-file-recursively "subprojects")))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-meson
+            (lambda _
+              (substitute* "meson.build"
+                (("gtk_update_icon_cache: true")
+                 "gtk_update_icon_cache: false")
+                (("update_desktop_database: true")
+                 "update_desktop_database: false"))))
+          (add-after 'unpack 'disable-nonfree-advertisement
+            (lambda _
+              (substitute* "src/ui/assistant.ui"
+                (("\\(standard for connecting to Windows\\)")
+                 "")
+                (("\\(standard for connecting to Linux\\)")
+                 "(standard for connecting to GNU/Linux)"))
+              (substitute* "src/ui/onboarding-dialog.ui"
+                (("Access Linux, Mac, and Windows")
+                 "Access many different")
+                (("multiplatform.svg")
+                 "welcome.svg")))))))
+    (inputs
+     (list gtk+ gtk-frdp gtk-vnc libhandy libsecret libxml2))
+    (native-inputs
+     (list gettext-minimal
+           `(,glib "bin")
+           itstool
+           pkg-config
+           vala))
+    (home-page "https://apps.gnome.org/Connections")
+    (synopsis "View and use other desktops")
+    (description "\
+Connections allows the user to connect to different machines or virtual
+machines.  It can be used to provide support to users who might need help.  It
+can use @acronym{VNC,Virtual Network Computing} and @acronym{RDP,Remote
+Desktop Protocol}.")
+    (license license:gpl3+)))