[bug#75558] gnu: python-cyvcf2: Update to 0.31.1

Message ID 5cca5fa72a4b9c00561e5f0ea34c3a790013ff25.1736871181.git.alexis.simon@runbox.com
State New
Headers
Series [bug#75558] gnu: python-cyvcf2: Update to 0.31.1 |

Commit Message

Alexis Simon Jan. 14, 2025, 4:13 p.m. UTC
  * gnu/packages/bioinformatics.scm (python-cyvcf2): Update to 0.31.1 and fix build failure.

Change-Id: Icc5057cf9f5e6ba141e6e29e8f4db657cd04c1d2
---
 gnu/packages/bioinformatics.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: d663d4b6cae2289bcdd8bdcd02d58ed30769f1e2
  

Comments

jgart Jan. 15, 2025, 3:13 a.m. UTC | #1
Thanks! Applied.
  

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 34a39a48f1..35f1a76fb1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2357,7 +2357,7 @@  (define-public python-cmseq
 (define-public python-cyvcf2
   (package
     (name "python-cyvcf2")
-    (version "0.30.28")
+    (version "0.31.1")
     (source
      (origin
        (method git-fetch)
@@ -2366,7 +2366,7 @@  (define-public python-cyvcf2
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "16yhfax509zyip8kkq2b0lflx5bdq5why7d785ayrqyzzq2rxqkk"))
+        (base32 "02x7ic2q4x3sfwx9n2sxg0a79iifjal0a68fqp9ljsfvdx4b7nq5"))
        (modules '((guix build utils)))
        (snippet
         ;; Delete bundled library
@@ -2395,7 +2395,7 @@  (define-public python-cyvcf2
               (setenv "CYTHONIZE" "1")
               (setenv "CYVCF2_HTSLIB_MODE" "EXTERNAL"))))))
     (inputs (list curl htslib libdeflate openssl zlib))
-    (native-inputs (list python-cython python-pytest))
+    (native-inputs (list python-cython python-pytest python-setuptools python-wheel))
     (propagated-inputs
      (list python-click
            python-coloredlogs