[bug#77337,1/3] gnu: gnome-initial-setup: Replace libgnomekbd with tecla.
Commit Message
This was changed in GNOME 45.
* gnu/packages/gnome.scm (gnome-initial-setup): Replace libgnomekbd with tecla.
Change-Id: I1fff5df07dbbb089a13b1d75095007064f2719c2
---
gnu/packages/gnome.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
@@ -1602,10 +1602,10 @@ (define-public gnome-initial-setup
;; Allow the "Preview" button in the keyboard layout
;; selection dialog to display the layout.
(substitute* "gnome-initial-setup/pages/keyboard/cc-input-chooser.c"
- (("\"gkbd-keyboard-display")
+ (("\"tecla")
(string-append "\"" (search-input-file
inputs
- "bin/gkbd-keyboard-display")))))))))
+ "bin/tecla")))))))))
(native-inputs
(list gettext-minimal
`(,glib "bin")
@@ -1624,7 +1624,6 @@ (define-public gnome-initial-setup
json-glib
mit-krb5
libadwaita
- libgnomekbd
libgweather4
libnma
libpwquality
@@ -1633,6 +1632,7 @@ (define-public gnome-initial-setup
packagekit
polkit
rest-next
+ tecla
upower
webkitgtk))
(synopsis "Initial setup wizard for GNOME desktop")