[bug#77339,mesa-updates,13/15] gnu: spirv-cross: Update to 1.4.309.0.
Commit Message
* gnu/packages/vulkan.scm (spirv-cross): Update to 1.4.309.0.
[arguments]<tests?>: Disable for now due to upstream issue hit when
update-reference-shaders phase is run, which is necessary to run the tests
successfully.
<phases>: Make the update-reference-shaders phase only run if tests are
enabled.
Change-Id: If496a258595af1bebf214972879ff6b4362e9743
---
gnu/packages/vulkan.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)
--
2.49.0
@@ -117,7 +117,7 @@ (define-public spirv-tools
(define-public spirv-cross
(package
(name "spirv-cross")
- (version "1.3.280.0")
+ (version "1.4.309.0")
(source
(origin
(method git-fetch)
@@ -125,11 +125,15 @@ (define-public spirv-cross
(url "https://github.com/KhronosGroup/SPIRV-Cross")
(commit (string-append "vulkan-sdk-" version))))
(sha256
- (base32 "1k6fbkradknxis85akzzksz9ipm3v42xvrzaamwj2lrgfm8d6r4d"))
+ (base32 "1sckwqz67mh48zypgr1r9x101mcq1dlkh8sxi341ynrxzjk8rm3j"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
+ `(;; Disable tests for now due to upstream issue hit when running
+ ;; update-reference-shaders phase:
+ ;; <https://github.com/KhronosGroup/SPIRV-Tools/issues/5980>.
+ #:tests? #f
+ #:configure-flags
(list "-DSPIRV_CROSS_SHARED=YES")
#:phases
(modify-phases %standard-phases
@@ -142,9 +146,10 @@ (define-public spirv-cross
(("\\$\\{CMAKE_(.*)_DIR\\}/external/spirv-tools(.*)/bin")
(string-append (assoc-ref inputs "spirv-tools") "/bin")))))
(add-before 'check 'update-reference-shaders
- (lambda _
- (with-directory-excursion "../source"
- (invoke "./update_test_shaders.sh")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "../source"
+ (invoke "./update_test_shaders.sh"))))))))
(inputs
(list glslang spirv-headers spirv-tools))
(native-inputs (list python))