diff mbox series

[bug#67493,gnome-team,v2,1/4] gnu: Add expected-lite

Message ID 5c5ee4632e7a6435f483337e4a4fbce31d49fc42.1701236254.git.saku@laesvuori.fi
State New
Headers show
Series [bug#67493,gnome-team,v2,1/4] gnu: Add expected-lite | expand

Commit Message

Saku Laesvuori Nov. 29, 2023, 5:40 a.m. UTC
* gnu/packages/cpp.scm (expected-lite): New variable.

Change-Id: I627bc4a811107b1c4fb9ed8f3e2a5b23043eb97c
---
 gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 60db3a6b3f6e4d1bd751d04b7d9ad1e894febf93
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 49e5b52e5f..5b59274659 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
 ;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2977,3 +2978,24 @@  (define-public tl-optional
 the std::optional for C++11/14/17, with support for monadic operations added in
 C++23.")
     (license license:cc0)))
+
+(define-public expected-lite
+  (package
+    (name "expected-lite")
+    (version "0.6.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/martinmoene/expected-lite")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d58nqh2fwdzdpln2wlnf898wyfxdnskq6ff33azbg92d5ibzys2"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/martinmoene/expected-lite")
+    (synopsis "Expected objects for C++11 and later")
+    (description "Expected lite is a single-file header-only library for
+objects that either represent a valid value or an error that you can pass
+by value. It is intended for use with C++11 and later")
+    (license license:boost1.0)))