@@ -136,7 +136,8 @@ (define-public sane-backends-minimal
(inputs
(list libusb))
(arguments
- `(#:phases
+ `(#:configure-flags '("--with-lockdir=/var/lock/sane") ;; Avoid errors with plustek
+ #:phases
(modify-phases %standard-phases
(add-before 'bootstrap 'zap-unnecessary-git-dependency
(lambda _
@@ -145,6 +146,12 @@ (define-public sane-backends-minimal
(("/bin/sh") (which "sh")))
(with-output-to-file ".tarball-version"
(lambda _ (format #t ,version)))))
+ (add-before 'configure 'disable-lockdir-creation
+ (lambda _
+ ;; Modify the Makefile.am to prevent the creation of the lock dir
+ (substitute* "backend/Makefile.am"
+ (("^install-lockpath:.*$")
+ "install-lockpath: # pass"))))
(add-before 'configure 'disable-backends
(lambda _
(setenv "BACKENDS" " ")