diff mbox series

[bug#40270,1/2] gnu: Add python-flask-markdown.

Message ID 5bbe56dd7abd7d2dedd737a61620ae36@airmail.cc
State Accepted
Headers show
Series [bug#40270,1/2] gnu: Add python-flask-markdown. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe March 28, 2020, 9:33 a.m. UTC
* gnu/packages/python-web.scm (python-flask-markdown, 
python2-flask-markdown): New variables.
---
  gnu/packages/python-web.scm | 30 ++++++++++++++++++++++++++++++
  1 file changed, 30 insertions(+)

      (name "python-html5lib")

Comments

Marius Bakke March 29, 2020, 8:10 p.m. UTC | #1
pinoaffe@airmail.cc writes:

> * gnu/packages/python-web.scm (python-flask-markdown, 
> python2-flask-markdown): New variables.

Note: I merged your previous bug report that adds this package (#40165)
with this bug (#40270).  The comments still stand however!  :-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b02ffd5f58..db66f1ed4d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -470,6 +470,36 @@  both of which are installed automatically if you 
install this library.")
  (define-public python2-flask-babel
    (package-with-python2 python-flask-babel))

+(define-public python-flask-markdown
+  (package
+    (name "python-flask-markdown")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Flask-Markdown" version))
+        (sha256
+          (base32
+            "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
+    (build-system python-build-system)
+    (arguments
+       `(#:tests? #f))
+    (propagated-inputs
+      `(("python-markdown" ,python-markdown)
+        ("python-flask" ,python-flask)))
+    (native-inputs
+      `(("python-nose" ,python-nose)))
+    (home-page
+      "http://github.com/dcolish/flask-markdown")
+    (synopsis
+      "Small extension to make using markdown in flask easy")
+    (description
+      "Small extension to make using markdown in flask easy")
+    (license license:bsd-3)))
+
+(define-public python2-flask-markdown
+  (package-with-python2 python-flask-markdown))
+
  (define-public python-html5lib
    (package