[bug#71457] gnu: Add emacs-devil.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-devil): New variable.
Change-Id: Ic240d6e80a236a91514f3599eaa051f9ffcd15be
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: bc8a41f4a8d9f1f0525d7bc97c67ed3c8aea3111
Comments
Hello,
Spencer King <spencer@nursiapress.com> writes:
> * gnu/packages/emacs-xyz.scm (emacs-devil): New variable.
Applied. Thank you.
Regards,
@@ -139,6 +139,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 Spencer King <spencer@nursiapress.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11029,6 +11030,28 @@ (define-public emacs-god-mode
@samp{C-} (among other helpful shortcuts).")
(license license:gpl3+)))
+(define-public emacs-devil
+ (package
+ (name "emacs-devil")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/susam/devil")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pr9yf6f37sz5qy1snn8ag5bvg6lza7q635jh8jhaqqfp37jvv1y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/susam/devil")
+ (synopsis "Minor mode for translating key sequences")
+ (description
+ "Devil intercepts your devil key (comma by default) to let you type key sequences
+without using modifier keys. Devil is highly configurable and it can be
+configured to perform other key sequence translations.")
+ (license license:expat)))
+
(define-public emacs-jinja2-mode
(package
(name "emacs-jinja2-mode")