diff mbox series

[bug#68530,2/2] gnu: Add u-boot-amlogic.

Message ID 5b7310aaa70a66eb3060d6f7cb0324b7eba0b30a.1705499841.git.herman@rimm.ee
State New
Headers show
Series [bug#68530,1/2] gnu: u-boot: Update to 2024.01.3. | expand

Commit Message

Herman Rimm Jan. 17, 2024, 1:59 p.m. UTC
From: Petr Hodina <phodina@protonmail.com>

* gnu/packages/bootloaders.scm (u-boot-amlogic): New variable.
---
 gnu/packages/bootloaders.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)


base-commit: b3e0a973bca6fe5de7356f3d70c4b7d468b0a759
prerequisite-patch-id: 582e61fddcf1ea430f1701460aae6707d59f69e3
prerequisite-patch-id: 9ec82bb85c0838f430d24e332fce35aa7ed9ca9e
prerequisite-patch-id: 57819e880d0c809667f6bf8626606b1babe63481
prerequisite-patch-id: 72858fea23cbc98dbc83cab4b714244f03685450
prerequisite-patch-id: cee17e48bf50155b92c8ea2218b01e4c7e3ce13d

Comments

Vagrant Cascadian Jan. 17, 2024, 7:13 p.m. UTC | #1
On 2024-01-17, Herman Rimm wrote:
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index 151b42210c..b354af06c8 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -894,6 +894,8 @@ (define-public u-boot-tools
>             (lambda* (#:key make-flags test-target #:allow-other-keys)
>               (invoke "test/image/test-imagetools.sh")))
>           ;; Only run full test suite on x86_64 systems, as many tests
> +
> +
>           ;; assume x86_64.
>           ,@(if (string-match "^x86_64-linux"
>                               (or (%current-target-system)

Is this whitespace change needed for some reason?


> @@ -1134,6 +1136,14 @@ (define*-public (make-u-boot-sunxi64-package board triplet scp-firmware
>         (modify-inputs (package-inputs base)
>           (append arm-trusted-firmware-sun50i-a64))))))
>  
> +(define %u-boot-amlogic-description-64-bit
> +  "This is a common 64-bit build of U-Boot for all 64-bit capable Amlogic s905x
> +variants.")
> +
> +(define-public u-boot-amlogic
> +  (make-u-boot-package "p212" "aarch64-linux-gnu"
> +                       #:append-description %u-boot-amlogic-description-64-bit))
> +

This should be called u-boot-p212. There are numerous other potential
amlogic platforms...

Although, an even bigger issues is that amlogic platforms all to my
knowledge require some non-free components in order to sign the binaries
before installing them, see the documentation in u-boot sources:

  doc/board/amlogic/p212.rst


live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 151b42210c..b354af06c8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -894,6 +894,8 @@  (define-public u-boot-tools
            (lambda* (#:key make-flags test-target #:allow-other-keys)
              (invoke "test/image/test-imagetools.sh")))
          ;; Only run full test suite on x86_64 systems, as many tests
+
+
          ;; assume x86_64.
          ,@(if (string-match "^x86_64-linux"
                              (or (%current-target-system)
@@ -1134,6 +1136,14 @@  (define*-public (make-u-boot-sunxi64-package board triplet scp-firmware
        (modify-inputs (package-inputs base)
          (append arm-trusted-firmware-sun50i-a64))))))
 
+(define %u-boot-amlogic-description-64-bit
+  "This is a common 64-bit build of U-Boot for all 64-bit capable Amlogic s905x
+variants.")
+
+(define-public u-boot-amlogic
+  (make-u-boot-package "p212" "aarch64-linux-gnu"
+                       #:append-description %u-boot-amlogic-description-64-bit))
+
 (define-public u-boot-pine64-plus
   (make-u-boot-sunxi64-package "pine64_plus" "aarch64-linux-gnu"
                                (delay crust-pine64-plus)))