diff mbox series

[bug#35489] gnu: Add guile-r7rs.

Message ID 5b666322c02ae4a729763414d2f036d2@hyper.dev
State Accepted
Headers show
Series [bug#35489] gnu: Add guile-r7rs. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amirouche April 29, 2019, 2:28 p.m. UTC

Comments

Amirouche May 1, 2019, 1:16 a.m. UTC | #1
Please put this patch on hold until #35518 is included somehow.


ref: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=35518
Amirouche July 15, 2019, 3:40 p.m. UTC | #2
see https://git.sr.ht/~amz3/guix-amz3-channel

<3
diff mbox series

Patch

From 06a0a886a03ef751eb068796a4aea37c57a6ebc6 Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Mon, 29 Apr 2019 16:27:08 +0200
Subject: [PATCH] gnu: Add guile-r7rs.

* gnu/packages/guile-xyz.scm (guile-r7rs): New variable.
---
 gnu/packages/guile-xyz.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 03fd63837e..d7866719b4 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2016 Eraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2016, 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
-;;; Copyright © 2016 Amirouche <amirouche@hypermove.net>
+;;; Copyright © 2016, 2019 Amirouche Boubekki <amirouche@hyper.dev>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2017 David Thompson <davet@gnu.org>
@@ -1550,6 +1550,34 @@  microAdapton.  Both miniAdapton and microAdapton are designed to be easy to
 understand, extend, and port to host languages other than Scheme.")
       (license license:expat))))
 
+(define-public guile-r7rs
+  (let ((commit "ea053dc524abb5e9e0d0ea7fc2da364acd21d731"))
+    (package
+      (name "guile-r7rs")
+      (version "0.1.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~amz3/guile-r7rs")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "0382flp13n9wgzhx8rrw4ldy2mac4mmzqij8zvclarc32d9mq0mp"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("guile" ,guile-2.2)))
+      (propagated-inputs
+       `(("guile-pfds" ,guile-pfds)))
+      (home-page "https://git.sr.ht/~amz3/guile-r7rs")
+      (synopsis "R7RS libraries for GNU Guile.")
+      (description "R7RS libraries for GNU Guile.")
+      (license license:lgpl3+))))
+
 (define-public guile-reader
   (package
     (name "guile-reader")
-- 
2.19.1