[bug#67755,v5,1/9] gnu: Add edlib.

Message ID 5af801299bc13936ebbd6d1cbc5076dc5f11b463.1741720525.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#67755,v5,1/9] gnu: Add edlib. |

Commit Message

Sergio Pastor Pérez March 11, 2025, 7:15 p.m. UTC
  From: Sergio Pastor Pérez <sergio.pastorperez@outlook.es>

* gnu/packages/cpp.scm (edlib): New variable.

Change-Id: Ia38b1d92d64134f638b13d9afb981f44a374a10e
---
 gnu/packages/cpp.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)


base-commit: 3bf7a0e8c431abfcba51806ee2a3eea9e0865472
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8d482d1fbd..338455b9fb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -43,7 +43,8 @@ 
 ;;; Copyright © 2024 Peepo Froggings <peepofroggings@tutanota.de>
 ;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
 ;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
-
+;;; Copyright © 2025 Sergio Pastor Pérez <sergio.pastorperez@gmail.com>
+;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -468,6 +469,28 @@  (define-public c2ffi
 various formats, including @code{json}.")
     (license license:gpl2+)))
 
+(define-public edlib
+  (package
+    (name "edlib")
+    (version "1.2.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Martinsos/edlib")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ibpxs3r8ii2s3g7kdbyr8brg6ha5l0fb21idw8531gx9v2qzh4v"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+    (home-page "https://github.com/Martinsos/edlib")
+    (synopsis "Lightweight C/C++ library for sequence alignment")
+    (description "Lightweight, C/C++ (& Python) library for sequence alignment
+using edit (Levenshtein) distance with a focus on speed.")
+    (license license:expat)))
+
 (define-public expected-lite
   (package
     (name "expected-lite")