diff mbox series

[bug#38118] gnu: Add avldrums-lv2.

Message ID 5a5e1c42fff47cdd168bd1380a94e218cf433e5c.camel@zrythm.org
State Accepted
Headers show
Series [bug#38118] gnu: Add avldrums-lv2. | expand

Commit Message

Alexandros Theodotou Nov. 11, 2019, 5:15 a.m. UTC
Oops, copy-paste fail. Added 2 spaces between sentences.

Comments

Marius Bakke Nov. 13, 2019, 10:33 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> From e6d30dd87ae46bfba50de7a0e549a13a0368dfcc Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:35:38 +0000
> Subject: [PATCH] gnu: Add avldrums-lv2.
>
> * gnu/packages/music.scm: (avldrums-lv2): New variable.

Thanks!  Applied with indentation fixes like the other patches.  This is
the last review I had time for today.

In the future, when sending many related patches at once, please send as
a "patch series" (commits on top of each other) instead of individual
patches all branching out from the same commit.

The reason is that applying the first patch to music.scm broke the other
patches for music.scm, because the context became different.  I managed
to work around it with a workflow involving
`git am --show-current-patch | git apply`, but it would be better if all
applied cleanly when committed in order.  :-)

Anyway, impressive first series of patches!  I look forward to the next
one.  ;-)
diff mbox series

Patch

From e6d30dd87ae46bfba50de7a0e549a13a0368dfcc Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:35:38 +0000
Subject: [PATCH] gnu: Add avldrums-lv2.

* gnu/packages/music.scm: (avldrums-lv2): New variable.
---
 gnu/packages/music.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..9d858ec6ff 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,48 @@  for integration into status line generators or other command-line tools.")
 effects.  It contains a bitcrusher, delay, distortion, equalizer, compressor,
 and reverb.")
     (license license:gpl2+)))
+
+(define-public avldrums-lv2
+  (package
+    (name "avldrums-lv2")
+    (version "0.4.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/x42/avldrums.lv2.git")
+            (commit (string-append "v" version))
+            ;; This plugin expects the robtk submodule's source files to be
+            ;; there in order to build
+            (recursive? #t)))
+        (file-name (string-append name "-v" version))
+        (sha256
+          (base32
+            "1z70rcq6z3gkb4fm8dm9hs31bslwr97zdh2n012fzki9b9rdj5qv"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _
+             (setenv "CC" "gcc") #t))
+         (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("dssi" ,dssi)
+       ("glu" ,glu)
+       ("mesa" ,mesa)
+       ("pango" ,pango)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lv2" ,lv2)))
+    (home-page "https://x42-plugins.com/x42/x42-avldrums")
+    (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux Drumkits")
+    (description "AVLdrums is a drum sample player LV2 plugin dedicated to Glen
+MacArthur's AVLdrums.  This plugin provides a convenient way to sequence and mix
+MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
+    (license license:gpl2+)))
-- 
2.24.0