diff mbox series

[bug#72016] gnu: emacs-lsp-mode: Enable plists.

Message ID 5a373bca3b425b39f4fdfae6d4a7e3c03a26e961.1720525931.git.dannym@scratchpost.org
State New
Headers show
Series [bug#72016] gnu: emacs-lsp-mode: Enable plists. | expand

Commit Message

Danny Milosavljevic July 9, 2024, 11:52 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
[enable-plists]: New phase.

Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
---
 gnu/packages/emacs-xyz.scm | 8 ++++++++
 1 file changed, 8 insertions(+)


base-commit: 13f0f52314244f08eb9fdd626d907c0c3976e06a

Comments

Ludovic Courtès July 18, 2024, 3:03 p.m. UTC | #1
Hey Danny!

Danny Milosavljevic <dannym@scratchpost.org> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
> [enable-plists]: New phase.
>
> Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
> ---
>  gnu/packages/emacs-xyz.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d5257f16a9..fd04e2432b 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -31169,6 +31169,14 @@ (define-public emacs-lsp-mode
>                (for-each (lambda (f)
>                            (install-file f "."))
>                          (find-files "clients/" "\\.el$"))))
> +          (add-after 'unpack 'enable-plists
> +            (lambda _
> +              (substitute* "lsp-protocol.el"
> +               ;; This is faster, and it's officially recommended,
> +               ;; and it's required by emacs-lsp-booster.
> +               ;; See also:
> +               ;; <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
> +               (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))

I’m know next to nothing about LSP, but that sounds reasonable to me!

Ludo’.
Liliana Marie Prikler July 21, 2024, 10:15 a.m. UTC | #2
Am Donnerstag, dem 18.07.2024 um 17:03 +0200 schrieb Ludovic Courtès:
> Hey Danny!
> 
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
> > [enable-plists]: New phase.
> > 
> > Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
> > ---
> >  gnu/packages/emacs-xyz.scm | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> > 
> > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > xyz.scm
> > index d5257f16a9..fd04e2432b 100644
> > --- a/gnu/packages/emacs-xyz.scm
> > +++ b/gnu/packages/emacs-xyz.scm
> > @@ -31169,6 +31169,14 @@ (define-public emacs-lsp-mode
> >                (for-each (lambda (f)
> >                            (install-file f "."))
> >                          (find-files "clients/" "\\.el$"))))
> > +          (add-after 'unpack 'enable-plists
> > +            (lambda _
> > +              (substitute* "lsp-protocol.el"
> > +               ;; This is faster, and it's officially recommended,
> > +               ;; and it's required by emacs-lsp-booster.
> > +               ;; See also:
> > +               ;;
> > <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
> > +               (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))
> 
> I’m know next to nothing about LSP, but that sounds reasonable to me!
I agree.  Pushed.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d5257f16a9..fd04e2432b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31169,6 +31169,14 @@  (define-public emacs-lsp-mode
               (for-each (lambda (f)
                           (install-file f "."))
                         (find-files "clients/" "\\.el$"))))
+          (add-after 'unpack 'enable-plists
+            (lambda _
+              (substitute* "lsp-protocol.el"
+               ;; This is faster, and it's officially recommended,
+               ;; and it's required by emacs-lsp-booster.
+               ;; See also:
+               ;; <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
+               (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))
           (add-before 'move-clients-libraries 'fix-patch-el-files
             ;; /bin/ksh is only used on macOS, which we don't support, so we
             ;; don't want to add it as input.