[bug#75502] gnu: Add dsda-doom.

Message ID 5a3645e2ccbbaac48e122e7f107581db3be0ef92.1736627244.git.wongandj@icloud.com
State New
Headers
Series [bug#75502] gnu: Add dsda-doom. |

Commit Message

Andrew Wong Jan. 11, 2025, 8:27 p.m. UTC
  * gnu/packages/games.scm (dsda-doom): New variable.

Change-Id: I1a999b1b5bf06a7cbe38aa0d4d0ccbb28430b1cf
---
 gnu/packages/games.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: f15ca836e4686496f675308655c370c95e9f52b7
  

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fb8018e271..15aebe7fc7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2557,6 +2557,52 @@  (define-public pipewalker
 Every puzzle has a complete solution, although there may be more than one.")
     (license license:gpl3+)))
 
+(define-public dsda-doom
+  (package
+    (name "dsda-doom")
+    (version "0.28.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kraflab/dsda-doom")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qvxx4r3ahiy8w9x0559g581971ycmbqm1kszzc65w1aa85f5q2f"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ;no tests
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'chdir
+                    (lambda _
+                      (chdir "prboom2"))))))
+    (inputs (list sdl2
+                  sdl2-mixer
+                  fluidsynth
+                  portmidi
+                  libmad
+                  libzip
+                  glu
+                  dumb
+                  libvorbis))
+    (home-page "https://github.com/kraflab/dsda-doom")
+    (synopsis "Successor of PrBoom+ with many new features")
+    (description
+     "This is a successor of prboom+ with many new features, including:
+@enumerate
+@item Heretic, Hexen, MBF21, Doom-in-Hexen, UDMF, and MAPINFO support
+@item In-game console and scripting
+@item Full controller support
+@item Palette-based opengl renderer
+@item Debugging features for testing
+@item Strict mode for speedrunning
+@item Various quality of life improvements
+@item Advanced tools for TASing
+@item Rewind
+@end enumerate")
+    (license license:gpl2+)))
+
 (define-public prboom-plus
   (package
    (name "prboom-plus")