diff mbox series

[bug#71428] gnu: Add orfondl.

Message ID 5a1d8c1400cf561f7ec9f92d41fd8b993b3d2856.1717831035.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#71428] gnu: Add orfondl. | expand

Commit Message

Liliana Marie Prikler June 8, 2024, 7:14 a.m. UTC
* gnu/packages/video.scm (orfondl): New variable.
(orf-dl): Deprecate in favor of orfondl.
---
 gnu/packages/video.scm | 74 +++++++++++++++++++++++++-----------------
 1 file changed, 44 insertions(+), 30 deletions(-)


base-commit: b8780f7397dd46b5e382e48db87b8648f769d738

Comments

Sharlatan Hellseher June 11, 2024, 9:28 a.m. UTC | #1
Hi,

Pushed as 693037101bbacb8de03457bbd3b231e1897c7b37 to master with minor
modifications.

--
Oleg
Sharlatan Hellseher June 11, 2024, 9:30 a.m. UTC | #2
This is a duplicate of https://issues.guix.gnu.org/71428, closing as not applied.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0960410498..b75ac958c1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -100,6 +100,7 @@  (define-module (gnu packages video)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
@@ -147,6 +148,7 @@  (define-module (gnu packages video)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnunet)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell-xyz)
@@ -2962,37 +2964,49 @@  (define libvpx/fixed
        (patches (search-patches "libvpx-CVE-2016-2818.patch"
                                 "libvpx-CVE-2023-5217.patch"))))))
 
-(define-public orf-dl
-  (let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
-        (revision "1"))
-    (package
-      (name "orf-dl")
-      (version (git-version "0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/tpoechtrager/orf_dl")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1w413miy01cm7rzb5c6wwfdnc2sqv87cvxwikafgrkswpimvdjsk"))))
-      (build-system copy-build-system)
-      (arguments
-       (list #:install-plan #~`(("orf_dl.php" "bin/orf-dl"))
-             #:phases
-             #~(modify-phases %standard-phases
-                 (add-after 'unpack 'patch-source
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     (substitute* "orf_dl.php"
-                       (("ffmpeg")
-                        (search-input-file inputs "bin/ffmpeg"))))))))
-      (inputs (list php ffmpeg))
-      (home-page "https://github.com/tpoechtrager/orf_dl")
-      (synopsis "Download videos from tvthek.orf.at")
-      (description "This package provides a PHP-based command line application
+(define-public orfondl
+  (package
+    (name "orfondl")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/badlogic/orfondl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0h1zcxxhvshbc3gkmr33npki6sdjh79haack1cci9k40a0gk144v"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:go go-1.19
+           #:import-path "github.com/badlogic/orfondl"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-source
+                 (lambda* (#:key inputs import-path #:allow-other-keys)
+                   (substitute* (string-append "src/" import-path "/main.go")
+                     (("\"ffmpeg\"")
+                      (string-append "\""
+                                     (search-input-file inputs "bin/ffmpeg")
+                                     "\"")))))
+               (replace 'build
+                 (lambda* (#:key import-path #:allow-other-keys #:rest args)
+                   (with-directory-excursion (string-append "src/" import-path)
+                     (apply (assoc-ref %standard-phases 'build) args))))
+               (replace 'check
+                 (lambda* (#:key import-path #:allow-other-keys #:rest args)
+                   (with-directory-excursion (string-append "src/" import-path)
+                     (apply (assoc-ref %standard-phases 'check) args)))))))
+    (inputs (list ffmpeg))
+    (home-page "https://github.com/tpoechtrager/orf_dl")
+    (synopsis "Download videos from ORF ON")
+    (description "This package provides a Go-based command line application
 to download videos from Austria's national television broadcaster.")
-      (license license:gpl2+))))
+    (license license:bsd-3)))
+
+(define-public orf-dl
+  (deprecated-package "orf-dl" orfondl))
 
 (define-public yle-dl
   (package